Não é possível instalar libpcre3-dev -- apt campo com package-management campo com dependencies camp askubuntu Relacionado O problema

Can't install libpcre3-dev


9
vote

problema

português

Eu estou tentando instalar mei 07 08:04:47 Ophelia gnome-shell[2197]: JS ERROR: TypeError: null has no properties _onFocusChanged@resource:///org/gnome/shell/ui/closeDialog.js:135:9 popModal@resource:///org/gnome/shell/ui/main.js:587:22 _continueDeactivate@resource:///org/gnome/shell/ui/screenShield.js:523:18 deactivate/<@resource:///org/gnome/shell/ui/screenShield.js:493:44 finish@resource:///org/gnome/shell/gdm/authPrompt.js:517:13 finish@resource:///org/gnome/shell/ui/unlockDialog.js:845:26 deactivate@resource:///org/gnome/shell/ui/screenShield.js:493:26 _onUserBecameActive@resource:///org/gnome/shell/ui/screenShield.js:305:18 _wakeUpScreen@resource:///org/gnome/shell/ui/screenShield.js:475:14 _init/<@resource:///org/gnome/shell/ui/unlockDialog.js:554:69 _countChanged@resource:///org/gnome/shell/ui/unlockDialog.js:272:18 _sourceAdded/obj.sourceCountChangedId<@resource:///org/gnome/shell/ui/unlockDialog.js:201:18 countUpdated@resource:///org/gnome/shell/ui/messageTray.js:791:15 pushNotification@resource:///org/gnome/shell/ui/messageTray.js:852:14 showNotification@resource:///org/gnome/shell/ui/messageTray.js:857:14 processNotification@resource:///org/gnome/shell/ui/notificationDaemon.js:469:18 _notifyForSource@resource:///org/gnome/shell/ui/notificationDaemon.js:355:16 NotifyAsync@resource:///org/gnome/shell/ui/notificationDaemon.js:226:18 _handleMethodCall@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:371:35 _wrapJSObject/<@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:404:34 0 mas me dá o erro de Follwing:

.

Os seguintes pacotes têm dependências não atendidas: libpcre3-dev: Depende: libpcre3 (= 2: 8.38-3.1) mas 2: 8.39-1 + deb.sury.org ~ Trusty + 1 é para ser instalado e: incapaz de corrigir problemas, você realizou pacotes quebrados.

o mei 07 08:04:47 Ophelia gnome-shell[2197]: JS ERROR: TypeError: null has no properties _onFocusChanged@resource:///org/gnome/shell/ui/closeDialog.js:135:9 popModal@resource:///org/gnome/shell/ui/main.js:587:22 _continueDeactivate@resource:///org/gnome/shell/ui/screenShield.js:523:18 deactivate/<@resource:///org/gnome/shell/ui/screenShield.js:493:44 finish@resource:///org/gnome/shell/gdm/authPrompt.js:517:13 finish@resource:///org/gnome/shell/ui/unlockDialog.js:845:26 deactivate@resource:///org/gnome/shell/ui/screenShield.js:493:26 _onUserBecameActive@resource:///org/gnome/shell/ui/screenShield.js:305:18 _wakeUpScreen@resource:///org/gnome/shell/ui/screenShield.js:475:14 _init/<@resource:///org/gnome/shell/ui/unlockDialog.js:554:69 _countChanged@resource:///org/gnome/shell/ui/unlockDialog.js:272:18 _sourceAdded/obj.sourceCountChangedId<@resource:///org/gnome/shell/ui/unlockDialog.js:201:18 countUpdated@resource:///org/gnome/shell/ui/messageTray.js:791:15 pushNotification@resource:///org/gnome/shell/ui/messageTray.js:852:14 showNotification@resource:///org/gnome/shell/ui/messageTray.js:857:14 processNotification@resource:///org/gnome/shell/ui/notificationDaemon.js:469:18 _notifyForSource@resource:///org/gnome/shell/ui/notificationDaemon.js:355:16 NotifyAsync@resource:///org/gnome/shell/ui/notificationDaemon.js:226:18 _handleMethodCall@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:371:35 _wrapJSObject/<@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:404:34 1 é de um 'velho' ppa (ondrej), então eu peguei um novo e novo fontes.list .

Eu tive o mesmo problema com mei 07 08:04:47 Ophelia gnome-shell[2197]: JS ERROR: TypeError: null has no properties _onFocusChanged@resource:///org/gnome/shell/ui/closeDialog.js:135:9 popModal@resource:///org/gnome/shell/ui/main.js:587:22 _continueDeactivate@resource:///org/gnome/shell/ui/screenShield.js:523:18 deactivate/<@resource:///org/gnome/shell/ui/screenShield.js:493:44 finish@resource:///org/gnome/shell/gdm/authPrompt.js:517:13 finish@resource:///org/gnome/shell/ui/unlockDialog.js:845:26 deactivate@resource:///org/gnome/shell/ui/screenShield.js:493:26 _onUserBecameActive@resource:///org/gnome/shell/ui/screenShield.js:305:18 _wakeUpScreen@resource:///org/gnome/shell/ui/screenShield.js:475:14 _init/<@resource:///org/gnome/shell/ui/unlockDialog.js:554:69 _countChanged@resource:///org/gnome/shell/ui/unlockDialog.js:272:18 _sourceAdded/obj.sourceCountChangedId<@resource:///org/gnome/shell/ui/unlockDialog.js:201:18 countUpdated@resource:///org/gnome/shell/ui/messageTray.js:791:15 pushNotification@resource:///org/gnome/shell/ui/messageTray.js:852:14 showNotification@resource:///org/gnome/shell/ui/messageTray.js:857:14 processNotification@resource:///org/gnome/shell/ui/notificationDaemon.js:469:18 _notifyForSource@resource:///org/gnome/shell/ui/notificationDaemon.js:355:16 NotifyAsync@resource:///org/gnome/shell/ui/notificationDaemon.js:226:18 _handleMethodCall@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:371:35 _wrapJSObject/<@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:404:34 2 e acabou desinstalando o PHP7.0 e instalando-o a partir dos repositórios oficiais.

Agora, quando eu quero remover mei 07 08:04:47 Ophelia gnome-shell[2197]: JS ERROR: TypeError: null has no properties _onFocusChanged@resource:///org/gnome/shell/ui/closeDialog.js:135:9 popModal@resource:///org/gnome/shell/ui/main.js:587:22 _continueDeactivate@resource:///org/gnome/shell/ui/screenShield.js:523:18 deactivate/<@resource:///org/gnome/shell/ui/screenShield.js:493:44 finish@resource:///org/gnome/shell/gdm/authPrompt.js:517:13 finish@resource:///org/gnome/shell/ui/unlockDialog.js:845:26 deactivate@resource:///org/gnome/shell/ui/screenShield.js:493:26 _onUserBecameActive@resource:///org/gnome/shell/ui/screenShield.js:305:18 _wakeUpScreen@resource:///org/gnome/shell/ui/screenShield.js:475:14 _init/<@resource:///org/gnome/shell/ui/unlockDialog.js:554:69 _countChanged@resource:///org/gnome/shell/ui/unlockDialog.js:272:18 _sourceAdded/obj.sourceCountChangedId<@resource:///org/gnome/shell/ui/unlockDialog.js:201:18 countUpdated@resource:///org/gnome/shell/ui/messageTray.js:791:15 pushNotification@resource:///org/gnome/shell/ui/messageTray.js:852:14 showNotification@resource:///org/gnome/shell/ui/messageTray.js:857:14 processNotification@resource:///org/gnome/shell/ui/notificationDaemon.js:469:18 _notifyForSource@resource:///org/gnome/shell/ui/notificationDaemon.js:355:16 NotifyAsync@resource:///org/gnome/shell/ui/notificationDaemon.js:226:18 _handleMethodCall@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:371:35 _wrapJSObject/<@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:404:34 3 ele quer remover quase todos os meus pacotes? Existe outra maneira de "mudar" o pacote libpcre3 para o "oficial"?

Eu também tentei , sem sorte

english

I am trying to install libpcre3-dev but it gives me the follwing error:

The following packages have unmet dependencies: libpcre3-dev : Depends: libpcre3 (= 2:8.38-3.1) but 2:8.39-1+deb.sury.org~trusty+1 is to be installed E: Unable to correct problems, you have held broken packages.

The 2:8.39-1+deb.sury.org~trusty+1 is from an 'old' ppa (ondrej), so I took a fresh and new Sources.list.

I had the same issue with php7.0-dev and ended up uninstalling php7.0 and installing it from the official repos.

Now when I want to remove libpcre3 it wants to remove nearly all of my packages? Is there another way to "change" the libpcre3 package to the "official" one?

I also tried this, with no luck

        

Lista de respostas

11
 
vote
vote
Melhor resposta
 

Use

  sudo apt-get install libpcre3=2:8.38-3.1 libpcre3-dev=2:8.38-3.1    

Para forçar apt-get para instalar a versão 2: 8.38-3.1 desses pacotes.

aviso: use apenas isso, se você tem certeza de que deseja instalar a versão 2: 8.38-3.1 (a versão do oficial ubuntu 16.04 < / forte> repositório) dos pacotes libpcre3 e libpcre3-dev .

Se você não estiver executando o Ubuntu 16.04, você deve alterar o número da versão para a versão que você realmente deseja instalar.

 

Use

sudo apt-get install libpcre3=2:8.38-3.1 libpcre3-dev=2:8.38-3.1 

to force apt-get to install version 2:8.38-3.1 of those packages.

Warning: Only use this this if you are really sure you want to install version 2:8.38-3.1 (the version from the official Ubuntu 16.04 repository) of the packages libpcre3 and libpcre3-dev.

If you are not running Ubuntu 16.04 you should change the version number to the version you actually want to install.

 
 
     
     

Perguntas relacionadas

2  Dependência de Libgcrypt11  ( Broken libgcrypt11 dependency ) 
Eu executo um comando casual apt-get update && apt-get upgrade . O processo concluído (com um erro): You might want to run 'apt-get -f install' to correct t...

0  Dependências de pacote não podem ser resolvidas ajuda [duplicada]  ( Package dependencies cannot be resolved help ) 
. Esta pergunta já tem respostas aqui : Como faço para resolver dependências não atendentes depois de...

0  Não é possível instalar qualquer coisa devido ao problema de dependência  ( Unable to install anything due to dependency problem ) 
Esta mensagem aparece toda vez que tento instalar qualquer coisa. Por favor, gente boa, eu estou contando com o Ubuntu. Eu não posso voltar para o Windows. P...

592  Como faço para resolver dependências não atendidas depois de adicionar um PPA?  ( How do i resolve unmet dependencies after adding a ppa ) 
Ocasionalmente, quando estou instalando coisas, recebo um erro como o seguinte: Some packages could not be installed. This may mean that you have requested...

1  Instalar Python2.7 Unet Dependências Problemas - Ubuntu 18.04  ( Install python2 7 unmet dependencies problems ubuntu 18 04 ) 
Eu recentemente limpo o Ubuntu 18.04 reinstalado e agora queria instalar o Python2.7 para várias outras dependências, no entanto, não conseguirá fazê-lo. RUNN...

2  12.04 Upgrade hosteu meu sistema  ( 12 04 upgrade hosed my system ) 
Eu gostaria de poder ser mais específico. Eu instalei a atualização do Gerenciador de Atualizações e depois que o computador for reinicializado, descobri que ...

2  libetpan15 não instalável ao tentar instalar o Cairo Dock  ( Libetpan15 not installable when trying to install cairo dock ) 
Ao adicionar Dock do Cairo ao Ubuntu 12.04, recebo esta mensagem me dizendo que eu preciso de uma dependência. O que faço agora para prosseguir com a instalaç...

0  Sudo apt-get -f Erro de instalação GCC-6-BASE  ( Sudo apt get f install error gcc 6 base ) 
Eu não posso instalar qualquer novo no meu comp Allways Obtendo este erro, mesmo que eu tente o sudo apt-get-get. Usando o Ubuntu 17,04 64 bits dpkg: depen...

0  Como instalar dependências do WebSocket ++?  ( How to install websocket dependencies ) 
Estou tentando desenvolver aplicativos do WebSocket em C ++. Escolhi para usar o WebSocket ++, pois é um não-absurdo #include que não tenta fallback no AJ...

3  Não é possível instalar o Office WPS [duplicado]  ( Cannot install wps office ) 
. Esta pergunta já tem respostas aqui : E: Pacote 'libpng12-0' não tem Candidato de instalação [Ubunt...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.