Ubuntu Server Repos [Duplicado] -- server campo com apt camp askubuntu Relacionado O problema

Ubuntu Server Repos [duplicate]


1
vote

problema

português
.

Quando eu estava instalando, pediu-me para configurar minha conexão com a Internet, mas porque o PC estou instalando não tem um cartão WiFi, e meu cabo Ethernet não estava dentro, eu não configurei uma rede. Ele está instalado agora, mas quando eu tento instalar qualquer coisa ou quando faço apt-get update , não funciona apenas diz

   Failed to fetch: http://...    

Alguém sabe como posso consertar isso? Eu pensei que eram os repositórios, então eu olhei para eles para adicionar / atualizá-los e eles estão bem. Meu amigo me disse para reinstalar com o cabo Ethernet, mas eu não quero fazer isso a menos que seja um último recurso.

english

When I was installing it asked me to set up my internet connection, but because the PC I'm installing it on doesn't have a WiFi card, and my Ethernet cable wasn't in, I didn't set up a network. It's installed now but when I try to install anything or when I do apt-get update, it doesn't work it just says

 Failed to fetch: http://... 

Does anyone know how I can fix this? I thought it was the repositories so I had a look at them to add/update them and they're fine. My friend told me to reinstall with the Ethernet cable in, but I don't want to do that unless its a last resort.

     
 
 

Lista de respostas

4
 
vote

Quando você instala offline, ele pode acontecer que um monte de repositórios desatualizados seja adicionado às suas fontes. Supondo que você tenha conectado via Ethernet agora, tudo o que você precisa fazer é corrigir as fontes. Remova o conteúdo quebrado do diretório sources.list.d , fazendo um backup primeiro (e digitando com cuidado!)

  cd /etc/apt  sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/*    

Agora tente atualizar novamente. Se você ainda tiver problemas, você precisa editar o sources.list e comentar (inserindo um # no início da linha) as entradas problemáticas

  sudo cp sources.list sources-bak sudoedit sources.list    

Deixe Descomedado pelo menos as linhas que mencionam os repositórios de atualizações de segurança e de segurança, e provavelmente você também quer manter os repositórios universo / multiverso. Comente o ABCDEFGHIJKLMNABCDEFGHIJKLMN5 Se você não quiser ativar o download do código-fonte. As coisas para manter parecer algo assim (dependendo da sua localização):

  deb http://us.archive.ubuntu.com/ubuntu/ xenial main restricted deb-src http://us.archive.ubuntu.com/ubuntu/ xenial main restricted  deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted  deb http://us.archive.ubuntu.com/ubuntu/ xenial universe deb-src http://us.archive.ubuntu.com/ubuntu/ xenial universe deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe  deb http://us.archive.ubuntu.com/ubuntu/ xenial multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial multiverse deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse  deb http://security.ubuntu.com/ubuntu xenial-security universe deb-src http://security.ubuntu.com/ubuntu xenial-security universe deb http://security.ubuntu.com/ubuntu xenial-security multiverse deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse    

Comente quaisquer linhas que mencionam o SourceForge ou outros repositórios externos à medida que os links são mais prováveis ​​desatualizados. Salvar e sair e você poderá atualizar.

Alternativamente, @anwar sugere, com base em sua própria experiência, que mudando seu espelho da regional para o espelho principal do Ubuntu poderia resolver o problema.

Para fazer isso, remova as etiquetas da região no ABCDEFGHIJKLMNABCDEFGHIJKLMN7 , substituindo, por exemplo, esta:

  http://us.archive.ubuntu.com/ubuntu    

com este

  http://archive.ubuntu.com/ubuntu    

Algumas sugestões para fazer isso rapidamente: faça uma cópia de backup como antes e use VIM ou VI: cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 0 e digite (substitua cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 1 com sua região):

.
  cd /etc/apt  sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 2   

Isso exclui instâncias de cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 3 mas é interativo para que você possa pressionar cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 4 para prosseguir ou cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 5 para pular e passar para a próxima instância. (Quando isso é feito tipo cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 6 para salvar e sair)

ou se você preferir (back up primeiro!):

  cd /etc/apt  sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 7   

Isso substitui todas as ocorrências de cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 8 com cd /etc/apt sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 9 (correspondência de um caractere extra apenas no caso de existe um sources.list0 em qualquer lugar que não queremos para excluir)

 

When you install offline, it can happen that a bunch of outdated repositories get added to your sources. Assuming you have connected via ethernet now, all you have to do is fix the sources. Remove the broken contents of the sources.list.d directory, making a backup first (and typing carefully!)

cd /etc/apt  sudo cp sources.list.d sources-d-bak sudo rm sources.list.d/* 

Now try to update again. If you still have problems, you need to edit the sources.list itself and comment out (by inserting a # at the start of the line) the problematic entries

sudo cp sources.list sources-bak sudoedit sources.list 

Leave uncommented at least the lines that mention main and security updates repositories, and most likely you also want to keep universe/multiverse repositories. Comment out the deb-src lines if you do not want to enable downloading source code. The things to keep look something like this (depending on your location):

deb http://us.archive.ubuntu.com/ubuntu/ xenial main restricted deb-src http://us.archive.ubuntu.com/ubuntu/ xenial main restricted  deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted  deb http://us.archive.ubuntu.com/ubuntu/ xenial universe deb-src http://us.archive.ubuntu.com/ubuntu/ xenial universe deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe  deb http://us.archive.ubuntu.com/ubuntu/ xenial multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial multiverse deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse  deb http://security.ubuntu.com/ubuntu xenial-security universe deb-src http://security.ubuntu.com/ubuntu xenial-security universe deb http://security.ubuntu.com/ubuntu xenial-security multiverse deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse 

Comment out any lines that mention sourceforge or other external repositories as the links are most likely outdated. Save and exit and you will be able to update.

Alternatively, @Anwar suggests, based on his own experience, that changing your mirror from the regional to the main Ubuntu mirror could solve the problem.

To do this, remove the region labels in the sources.list, replacing, for example, this:

http://us.archive.ubuntu.com/ubuntu 

with this

http://archive.ubuntu.com/ubuntu 

Some suggestions to do this quickly: Make a backup copy as before, then use Vim or Vi: sudo vi /etc/apt/sources.list and type (replace us. with your region):

:%s/us.//gc 

This deletes instances of us. but is interactive so you can press y to proceed or n to skip and move to the next instance. (When that is done type :wq to save and exit)

or if you prefer (back up first!):

sudo sed -i 's/\/us./\//g' /etc/apt/sources.list 

This replaces all occurrences of /us. with / (matching an extra character just in case there is a us. anywhere we don't want to delete)

 
 
     
     

Perguntas relacionadas

0  Apt "conexão falhou"  ( Apt connection failed ) 
Desde a instalação do Ubuntu, não consegui instalar novos pacotes, ele ainda não foi atualizado. Abaixo está uma despejo de erro de conexão que vejo quando te...

1  Quais são os vários 'anúncios' ou 'avisos' para atualizações de pacotes?  ( What are the various announcements or notices for package updates ) 
Recentemente, me deparei com o USN - Notices de segurança do Ubuntu e a DSA - Debian Security anuncie e descobriu que estas são as listas de email para as atu...

3  Não é possível instalar drivers para o meu cartão WiFi Realtek RTL8723BE no Ubuntu 16.10  ( Cannot install drivers for my realtek rtl8723be wifi card in ubuntu 16 10 ) 
tentou $ sudo add-apt-repository ppa:hanipouspilot/rtlwifi $ sudo apt-get update $ sudo apt-get install rtlwifi-new-dkms linux-firmware mas dar ...

5  Equivalente à história do yum?  ( Equivalent to yum history ) 
Existe um equivalente a yum history comando no Ubuntu? Estou ciente de que posso apenas olhar para os logs apt, mas estou procurando por algo que irá listá-...

1  / usr / local / bin / bower: Nenhum arquivo ou diretório após reinstalar o Node.js e bower  ( Usr local bin bower no such file or directory after reinstalling node js and b ) 
Eu reinstalei nodejs ( node , npm ) por causa de uma antiga configuração corrompida. Do que eu instalei bower $sudo npm install -g bower /usr/bin/bowe...

1  O sistema caiu, mostrando o terminal 'Configurando a caixa de inicialização segura'  ( System has crashed terminal showing configuring secure boot box ) 
Eu tentei atualizar o XFCE Desktop com - sudo apt-get upgrade xfce4 Por razões desconhecidas, o processo não foi concluído. Depois disso sempre que eu ...

2  Erro ao adicionar um repositório a /etc/apt/sources.list  ( Error adding a repository to etc apt sources list ) 
no Ubuntu 14.04, segui http: //mirror.its. dal.ca/cran/bin/linux/ubuntu/readme que diz Installation and compilation of R or some of its packages may requ...

1  Não é possível instalar o IDE do Lazarus no Ubuntu 10.04  ( Cannot install lazarus ide on ubuntu 10 04 ) 
Eu baixei arquivos * .deb da página inicial do Lázaro e usada sudo dpkg -i *.deb na pasta lábarus. Isso instalou, mas não pôde ser devido ao erro dizen...

1  Gnome-Software Manager ficando em RAM quando fechado xubuntu 16.04  ( Gnome software manager staying in ram when closed xubuntu 16 04 ) 
Vou executar gnome-software 3.20.1 e feche o programa. No entanto, o processo do programa não fecha e ocupa um pedaço notável de memória. O programa também ...

9  Mesclar vários arquivos MP4 em um único vídeo através do terminal [duplicado]  ( Merge multiple mp4 files into a single video via the terminal ) 
. Esta pergunta já tem respostas aqui : O que o software pode participar de vídeos? ...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.