Corrigir dependências do pacote? -- 14.04 campo com command-line campo com apt campo com software-installation campo com dpkg camp askubuntu Relacionado O problema

Fix Package Dependencies?


1
vote

problema

português

Estou tentando instalar o Build-essential usando ABCDEFGHIJKLMNABCDEFGHIJKLMN0 como se eu estivesse. Retorna com o erro

      The following packages have unmet dependencies:      build essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed     E: Unable to correct problems, you have held broken packages.    

Eu tentei usar algumas correções diferentes, como sudo apt-get install -f e sudo apt-get update , bem como sudo apt-get upgrade mas nenhum tenha corrigido os pacotes. Ao usar sudo apt-get install -f é que terminal me diz.

      Reading package lists... Done     Building dependency tree            Reading state information... Done     The following packages were automatically installed and are no longer required:       linux-image-3.19.0-25-generic linux-image-extra-3.19.0-25-generic     Use 'apt-get autoremove' to remove them.     0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.    

Outras opções Retornam nada. Eu olhei para alguns outros guias e perguntas, mas nenhum funcionou. Eu tentei dpkg -i para tentar, para que ele instale as dependências para mim, eu tentei seguir o labrynth eu e instalar as dependências à mão, mas acabei de ter mais e mais dependências até que não pudesse encontrar a luz no final do túnel frio de dependências. Existe uma maneira fácil de instalar o Build - essencial através do terminal que eu não estou usando, ou há um comando que pode instalar essa longa lista de dependências para mim? Eu acho que incluí todas as informações que você precisará. Este é um link para o guia abcdefghgjklmnabcdefghijklmn8 que eu tentei-- Como deixar" DPKG -i "instalar dependências para mim? Se houver informações adicionais necessárias, posso obtê-lo para você!

edit:

Aqui está a saída de apt-cache policy build-essential g++ .

      The following packages have unmet dependencies:      build essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed     E: Unable to correct problems, you have held broken packages. 0   

Eu também corri para a solução de outra pessoa e não funcionou, mas notei algo interessante no código, então eu corri The following packages have unmet dependencies: build essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 1 uma segunda vez para obter as informações por conta própria. Aqui está o que eu consegui. Não tenho certeza do que significa ou como corrigi-lo. Se alguém puder responder a qualquer uma das múltiplas perguntas aqui que seriam muito úteis! Obrigado!

      The following packages have unmet dependencies:      build essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed     E: Unable to correct problems, you have held broken packages. 2   

Eu tentei executar The following packages have unmet dependencies: build essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 3 e The following packages have unmet dependencies: build essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 4 depois que eu vi isso, mas acabei de receber a mesma saída de antes.

english

I'm trying to install build-essential using sudo apt-get install build-essential like I'm supposed to. It returns with the error

    The following packages have unmet dependencies:      build essential : Depends: g++ (>= 4:4.4.3) but it is not going to be installed     E: Unable to correct problems, you have held broken packages. 

I have tried to use a few different fixes, like sudo apt-get install -f and sudo apt-get update as well as sudo apt-get upgrade but none have fixed the packages. When using sudo apt-get install -f this is what terminal tells me.

    Reading package lists... Done     Building dependency tree            Reading state information... Done     The following packages were automatically installed and are no longer required:       linux-image-3.19.0-25-generic linux-image-extra-3.19.0-25-generic     Use 'apt-get autoremove' to remove them.     0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded. 

Other options return nothing. I looked up a few other guides and questions, but none worked. I tried dpkg -i to try and let it install the dependencies for me, I tried following the labrynth myself and installing the dependencies by hand, but I just got more and more dependencies until I couldn't find the light at the end of the cold tunnel of dependencies. Is there an easy way to install build-essential through terminal that I'm not using, or is there a command that can install this long list of dependencies for me? I think I've included all the information that you'll need. This is a link to the dpkg -i guide that I tried-- How to let `dpkg -i` install dependencies for me? If there is additional information needed I can get it to you!

EDIT:

Here is the output of apt-cache policy build-essential g++.

    build-essential:       Installed: (none)       Candidate: 11.6ubuntu6       Version table:          11.6ubuntu6 0             500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages     g++:       Installed: (none)       Candidate: 4:4.8.2-1ubuntu6       Version table:          4:4.8.2-1ubuntu6 0             500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages 

I also ran someone else's solution and it didn't work, but I noticed something interesting in the code so I ran sudo apt-get dist-upgrade a second time to get the information on its own. Here's what I got. I'm not sure what it means or how to fix it. If anyone can answer any of the multiple questions here that'd be very helpful! Thank you!

    $ sudo apt-get dist-upgrade     Reading package lists... Done     Building dependency tree            Reading state information... Done     Calculating upgrade... Done     The following packages have been kept back:       cpp-4.8 gcc-4.8-base gcc-4.8-base:i386 libasan0     0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded. 

I tried to run sudo apt-get updates and sudo apt-get install -f after I saw this, but I just got the same output as before.

              
   
   

Lista de respostas

2
 
vote

Eu só sei duas maneiras de fazer isso é: sudo apt-get install -f e o outro é para baixar tudo manualmente através de um navegador e colocar pacotes dentro de abcdefghijklmnabcdefgijklmn8 (a pasta onde Pacotes baixados reside) e ligue para a instalação novamente.

Você pode verificar a integridade dos pacotes apenas no caso de corrupção é a razão de dependência não foi resolvida. Meu kung fu não é mais profundo do que isso. Você também pode tentar purgar, então auroremove e ligar a instalação novamente no software que você deseja.

 

I only know two ways to do this one is : sudo apt-get install -f and the other is to download everything manually via a browser and putting packages inside of /var/cache/apt/archives (the folder where downloaded packages reside) and call the install again.

You can check the integrity of packages just in case corruption is the reason of dependency been unsolved. My Kung fu is not deeper than that. You can also try purging, then auroremove and call installation again on the software you want.

 
 
     
     
0
 
vote
vote
Melhor resposta
 

Esta pode ser uma solução específica da situação (eu nunca tive isso acontecer duas vezes, então eu não sei) Mas quando eu corri sudo pip3 uninstall keras0 instalou todas as dependências. Outra maneira de instalar dependências pode ser através de sudo pip3 uninstall keras1 (não tenho certeza sobre isso. Eu nunca usei, mas depois de alguma pesquisa eu acredito que funcionaria). Eu tentei instalar outros pacotes usando sudo pip3 uninstall keras2 e nunca me pediu para corrigir dependências novamente.

 

This may be a situation specific fix (I've never had this happen twice so I don't know) but when I ran sudo apt-get install build-essential checkinstall it installed all dependencies. Another way to install dependencies may be through gdebi (not sure on that one either. I've never used it, but after some research I believe it would work). I've tried installing other packages using sudo apt-get install package checkinstall and it's never asked me to fix dependencies again.

 
 

Perguntas relacionadas

2  Incapaz de purgar mysql -server  ( Unable to purge mysql server ) 
Eu sou novo para o Ubuntu. Eu estou tentando desinstalar o MySQL-Server, enquanto estou fazendo o processo de purga é preso na linha Renaming removed key_buf...

4  Como definir o status da seleção do pacote para o status atual?  ( How to set the package selection status to the current status ) 
Eu fiz um comando dpkg --clear-selections e descobri que todos os meus pacotes são selecionados para remoção. Como as páginas do homem está dizendo . - ...

5  Não é possível remover Qtspim do Ubuntu 14.04 LTS  ( Cannot remove qtspim from ubuntu 14 04 lts ) 
Eu tentei recentemente instalar o SPIM (compilador MIPS) na minha máquina e não funcionou. Agora estou tentando remover a coisa toda, mas simplesmente não pos...

0  Sudo apt-get -f Erro de instalação GCC-6-BASE  ( Sudo apt get f install error gcc 6 base ) 
Eu não posso instalar qualquer novo no meu comp Allways Obtendo este erro, mesmo que eu tente o sudo apt-get-get. Usando o Ubuntu 17,04 64 bits dpkg: depen...

3  dpkg sem shell  ( Dpkg with no shell ) 
Como executar o dpkg sem shell? Aqui está o meu problema: Eu furo e script autorun.sh na minha chave USB. Para executar este script, criei regras em /e...

33  Usuário desconhecido no arquivo StatomerRide  ( Unknown user in statoverride file ) 
Eu tinha um aplicativo instalado no meu HTPC executando o servidor Ubuntu chamado Mediatomb, há alguns meses eu desinstalei e substituí-lo por uma instalação ...

4  Não é possível instalar nada, erro de dpkg  ( Cant install anything dpkg error ) 
Eu não posso instalar nada no meu ubuntu .. eu googled, encontrei o mesmo problema, mas nenhuma das soluções propostas resolveu meu problema .. o tempo todo, ...

10  O que significa "II" em saída de comando "dpkg -list"? [duplicado]  ( What does ii mean in dpkg list command output ) 
. Esta pergunta já tem respostas aqui : O que os vários sinalizadores DPKG como 'II' 'RC' significa ?...

9  Como resolver o erro "Usuário desconhecido" Elasticsearch "no arquivo StatOverRide"?  ( How to resolve unknown user elasticsearch in statoverride file error ) 
Eu tenho tentado instalar a pesquisa elástica, eu baixei o arquivo abcdefghgjklmnabcdefghijklmn0 . Quando tento usar o comando: sudo dpkg -i elasticsearch...

8  O subprocesso de instalação do Docker-CE nunca termina  ( Docker ce post installation subprocess never finishes ) 
Eu tentei instalar docker-ce seguindo as instruções fornecidas na documentação oficial do Docker Usando o repositório . A instalação ficou preso neste mome...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.