Lenovo Z50-75 80EC | QCA6164 802.11AC adaptador de rede sem fio | Não está funcionando -- networking campo com wireless campo com drivers campo com lenovo campo com atheros camp askubuntu Relacionado O problema

Lenovo Z50-75 80EC | QCA6164 802.11ac Wireless Network Adapter | Not working


1
vote

problema

português

Atualmente, meu wireless não parece querer trabalhar para mim, e parece que eu tenho um driver ativo listado ao executar o comando lshw;

    zero@zero-Lenovo-Z50-75:~$ sudo lshw -C network  *-network     description: Network controller     product: QCA6164 802.11ac Wireless Network Adapter     vendor: Qualcomm Atheros     physical id: 0     bus info: pci@0000:02:00.0     version: 20     width: 64 bits     clock: 33MHz     capabilities: pm msi pciexpress bus_master cap_list     configuration: driver=ath10k_pci latency=0     resources: irq:35 memory:f0800000-f09fffff    

e tudo parece bem do que posso dizer ao executar os comandos lspci e lsmod

    zero@zero-Lenovo-Z50-75:~$ lspci | grep Network 02:00.0 Network controller: Qualcomm Atheros QCA6164 802.11ac Wireless Network Adapter (rev 20)    

.

  zero@zero-Lenovo-Z50-75:~$ lsmod | grep ath  ath10k_pci             45056  0  ath10k_core           311296  1 ath10k_pci  ath                    32768  1 ath10k_core  mac80211              737280  1 ath10k_core  cfg80211              565248  3 ath,mac80211,ath10k_core    

Eu puxei um pouco mais de informação também

   zero@zero-Lenovo-Z50-75:~$ lspci -nnk | grep 0280 -A2  02:00.0 Network controller [0280]: Qualcomm Atheros QCA6164 802.11ac Wireless Network Adapter [168c:0041] (rev 20)      Subsystem: Lenovo QCA6164 802.11ac Wireless Network Adapter [17aa:3545]      Kernel driver in use: ath10k_pci    

.

   zero@zero-Lenovo-Z50-75:~$ uname -r  4.4.0-21-generic    

Eu estou em execução em uma versão recém-instalada de 16.04, e passei pelo guia de solução de problemas sem fio, https://help.ubuntu.com/community/wifidocs/wirelessfroubleshootingguide/devices , sem sucesso real, mas foi capaz de pelo menos retirar essas informações. Qualquer pessoa tem alguma ideia sobre como eu posso ficar sem fio para trabalhar neste dispositivo?

update Correu o comando solicitado e recebeu o seguinte

  zero@zero-Lenovo-Z50-75:~$ dmesg | grep ath [   14.158205] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0 [   14.416562] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2 [   14.800570] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA6174/hw2.1/board-2.bin failed with error -2 [   16.012966] ath10k_pci 0000:02:00.0: firmware crashed! (uuid fd35c83e-b588-42c9-8b35-9732809f4865) [   16.012996] ath10k_pci 0000:02:00.0: qca6164 hw2.1 (0x05010000, 0x003405ff sub 17aa:3545) fw WLAN.RM.1.1-00141 fwapi 5 bdapi 1 htt-ver 0.0 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp,no-4addr-pad [   16.013002] ath10k_pci 0000:02:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0 [   16.013340] ath10k_pci 0000:02:00.0: firmware register dump: [   16.013346] ath10k_pci 0000:02:00.0: [00]: 0x05010000 0x000015B3 0x000A012D 0x00955B31 [   16.013352] ath10k_pci 0000:02:00.0: [04]: 0x000A012D 0x00060330 0x00000016 0x89785006 [   16.013356] ath10k_pci 0000:02:00.0: [08]: 0x00000000 0x00400000 0x00400600 0x00000001 [   16.013361] ath10k_pci 0000:02:00.0: [12]: 0x00000009 0x00000000 0x00931C61 0x00931C7D [   16.013366] ath10k_pci 0000:02:00.0: [16]: 0x0096BDBC 0x009286B6 0x00000000 0x00000000 [   16.013370] ath10k_pci 0000:02:00.0: [20]: 0x400A012D 0x0040E2B0 0x00955A00 0x00404590 [   16.013375] ath10k_pci 0000:02:00.0: [24]: 0x809287D9 0x0040E310 0x7A508EF8 0xC00A012D [   16.013380] ath10k_pci 0000:02:00.0: [28]: 0x809288D7 0x0040E340 0x00000000 0xFFF08040 [   16.013384] ath10k_pci 0000:02:00.0: [32]: 0x809290FE 0x0040E360 0x00400000 0x00400600 [   16.013389] ath10k_pci 0000:02:00.0: [36]: 0x80929205 0x0040E380 0x00000000 0x00400600 [   16.013394] ath10k_pci 0000:02:00.0: [40]: 0x40928024 0x0040E3B0 0x0040D3D0 0x0040D3D0 [   16.013398] ath10k_pci 0000:02:00.0: [44]: 0x00000000 0x0040E3D0 0x009BB001 0x00040020 [   16.013403] ath10k_pci 0000:02:00.0: [48]: 0x00401BF0 0x00000001 0x00404B9C 0x00400000 [   16.013407] ath10k_pci 0000:02:00.0: [52]: 0x40928024 0x0040E3B0 0x0040D3D0 0x0040D3D0 [   16.013416] ath10k_pci 0000:02:00.0: [56]: 0xE5EEA500 0xB43332FF 0xE7B7BE94 0x100D76CF [   17.008219] ath10k_pci 0000:02:00.0: failed to receive control response completion, polling.. [   18.008124] ath10k_pci 0000:02:00.0: ctl_resp never came in (-110) [   18.008132] ath10k_pci 0000:02:00.0: failed to connect to HTC: -110 [   18.086191] ath10k_pci 0000:02:00.0: could not init core (-110) [   18.086230] ath10k_pci 0000:02:00.0: could not probe fw (-110) [   18.792102] ath10k_pci 0000:02:00.0: cannot restart a device that hasn't been started    

**************************************** <***************

   zero@zero-Lenovo-Z50-75:~$ dmesg | grep ath  [   13.176301] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0  [   13.499398] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2  [   14.854563] ath10k_pci 0000:02:00.0: qca6164 hw2.1 (0x05010000, 0x003405ff sub 17aa:3545) fw SW_RM.1.1.1-00157-QCARMSWPZ-1 fwapi 5 bdapi 2 htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp,no-4addr-pad  [   14.854570] ath10k_pci 0000:02:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0  [   14.854757] ath10k_pci 0000:02:00.0: no channel configured; ignoring frame(s)!  [   14.931417] ath: EEPROM regdomain: 0x6c  [   14.931423] ath: EEPROM indicates we should expect a direct regpair map  [   14.931428] ath: Country alpha2 being used: 00  [   14.931431] ath: Regpair used: 0x6c  [   15.070970] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0  [   29.218751] ath10k_pci 0000:02:00.0: no channel configured; ignoring frame(s)!  [   89.179591] ath10k_pci 0000:02:00.0: no channel configured; ignoring frame(s)!    

Desculpe pelo atraso em repostagem, levei um pouco para chegar a uma conexão de linha rígida. Eu corri através dos comandos recomendados para atualizar os drivers de Ath10k e nós levantamos. Atualmente estou conectado via WiFi sem problemas até agora. Vou tentar acompanhar isso após 72 horas ou mais de uso.

english

Currently my wireless does not seem to want to work for me, and it looks like I have an active driver listed when running lshw command;

  zero@zero-Lenovo-Z50-75:~$ sudo lshw -C network  *-network     description: Network controller     product: QCA6164 802.11ac Wireless Network Adapter     vendor: Qualcomm Atheros     physical id: 0     bus info: pci@0000:02:00.0     version: 20     width: 64 bits     clock: 33MHz     capabilities: pm msi pciexpress bus_master cap_list     configuration: driver=ath10k_pci latency=0     resources: irq:35 memory:f0800000-f09fffff 

And everything looks okay from what I can tell when running lspci and lsmod commands

  zero@zero-Lenovo-Z50-75:~$ lspci | grep Network 02:00.0 Network controller: Qualcomm Atheros QCA6164 802.11ac Wireless Network Adapter (rev 20) 

.

zero@zero-Lenovo-Z50-75:~$ lsmod | grep ath  ath10k_pci             45056  0  ath10k_core           311296  1 ath10k_pci  ath                    32768  1 ath10k_core  mac80211              737280  1 ath10k_core  cfg80211              565248  3 ath,mac80211,ath10k_core 

I pulled a little more information as well

 zero@zero-Lenovo-Z50-75:~$ lspci -nnk | grep 0280 -A2  02:00.0 Network controller [0280]: Qualcomm Atheros QCA6164 802.11ac Wireless Network Adapter [168c:0041] (rev 20)      Subsystem: Lenovo QCA6164 802.11ac Wireless Network Adapter [17aa:3545]      Kernel driver in use: ath10k_pci 

.

 zero@zero-Lenovo-Z50-75:~$ uname -r  4.4.0-21-generic 

I am running on a freshly installed version of 16.04, and have gone through the Wireless Troubleshooting guide, https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide/Devices, with no real success, but was able to at least pull off of this information. Anyone have any ideas on how I can get wireless to work on this device?

UPDATE Ran the requested command and received the following

zero@zero-Lenovo-Z50-75:~$ dmesg | grep ath [   14.158205] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0 [   14.416562] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2 [   14.800570] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA6174/hw2.1/board-2.bin failed with error -2 [   16.012966] ath10k_pci 0000:02:00.0: firmware crashed! (uuid fd35c83e-b588-42c9-8b35-9732809f4865) [   16.012996] ath10k_pci 0000:02:00.0: qca6164 hw2.1 (0x05010000, 0x003405ff sub 17aa:3545) fw WLAN.RM.1.1-00141 fwapi 5 bdapi 1 htt-ver 0.0 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp,no-4addr-pad [   16.013002] ath10k_pci 0000:02:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0 [   16.013340] ath10k_pci 0000:02:00.0: firmware register dump: [   16.013346] ath10k_pci 0000:02:00.0: [00]: 0x05010000 0x000015B3 0x000A012D 0x00955B31 [   16.013352] ath10k_pci 0000:02:00.0: [04]: 0x000A012D 0x00060330 0x00000016 0x89785006 [   16.013356] ath10k_pci 0000:02:00.0: [08]: 0x00000000 0x00400000 0x00400600 0x00000001 [   16.013361] ath10k_pci 0000:02:00.0: [12]: 0x00000009 0x00000000 0x00931C61 0x00931C7D [   16.013366] ath10k_pci 0000:02:00.0: [16]: 0x0096BDBC 0x009286B6 0x00000000 0x00000000 [   16.013370] ath10k_pci 0000:02:00.0: [20]: 0x400A012D 0x0040E2B0 0x00955A00 0x00404590 [   16.013375] ath10k_pci 0000:02:00.0: [24]: 0x809287D9 0x0040E310 0x7A508EF8 0xC00A012D [   16.013380] ath10k_pci 0000:02:00.0: [28]: 0x809288D7 0x0040E340 0x00000000 0xFFF08040 [   16.013384] ath10k_pci 0000:02:00.0: [32]: 0x809290FE 0x0040E360 0x00400000 0x00400600 [   16.013389] ath10k_pci 0000:02:00.0: [36]: 0x80929205 0x0040E380 0x00000000 0x00400600 [   16.013394] ath10k_pci 0000:02:00.0: [40]: 0x40928024 0x0040E3B0 0x0040D3D0 0x0040D3D0 [   16.013398] ath10k_pci 0000:02:00.0: [44]: 0x00000000 0x0040E3D0 0x009BB001 0x00040020 [   16.013403] ath10k_pci 0000:02:00.0: [48]: 0x00401BF0 0x00000001 0x00404B9C 0x00400000 [   16.013407] ath10k_pci 0000:02:00.0: [52]: 0x40928024 0x0040E3B0 0x0040D3D0 0x0040D3D0 [   16.013416] ath10k_pci 0000:02:00.0: [56]: 0xE5EEA500 0xB43332FF 0xE7B7BE94 0x100D76CF [   17.008219] ath10k_pci 0000:02:00.0: failed to receive control response completion, polling.. [   18.008124] ath10k_pci 0000:02:00.0: ctl_resp never came in (-110) [   18.008132] ath10k_pci 0000:02:00.0: failed to connect to HTC: -110 [   18.086191] ath10k_pci 0000:02:00.0: could not init core (-110) [   18.086230] ath10k_pci 0000:02:00.0: could not probe fw (-110) [   18.792102] ath10k_pci 0000:02:00.0: cannot restart a device that hasn't been started 

******************UPDATE******************

 zero@zero-Lenovo-Z50-75:~$ dmesg | grep ath  [   13.176301] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0  [   13.499398] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2  [   14.854563] ath10k_pci 0000:02:00.0: qca6164 hw2.1 (0x05010000, 0x003405ff sub 17aa:3545) fw SW_RM.1.1.1-00157-QCARMSWPZ-1 fwapi 5 bdapi 2 htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp,no-4addr-pad  [   14.854570] ath10k_pci 0000:02:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0  [   14.854757] ath10k_pci 0000:02:00.0: no channel configured; ignoring frame(s)!  [   14.931417] ath: EEPROM regdomain: 0x6c  [   14.931423] ath: EEPROM indicates we should expect a direct regpair map  [   14.931428] ath: Country alpha2 being used: 00  [   14.931431] ath: Regpair used: 0x6c  [   15.070970] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0  [   29.218751] ath10k_pci 0000:02:00.0: no channel configured; ignoring frame(s)!  [   89.179591] ath10k_pci 0000:02:00.0: no channel configured; ignoring frame(s)! 

Sorry for the delay in reposting, took me a while to get to a hard-line connection. I ran through the commands recommended to update the ath10k drivers and we have lift off. I'm currently connected via WiFi with no issues so far. I'll try to follow up on this after 72 hours or so of use.

              
   
   

Lista de respostas

2
 
vote
vote
Melhor resposta
 

Vamos tentar firmware diferente. Com uma conexão de internet trabalhadora por Ethernet, amarrado ou qualquer meio possível, abra um terminal e faça:

  sudo apt-get update sudo apt-get install git git clone https://github.com/kvalo/ath10k-firmware.git cd ath10k-firmware/QCA6174/hw2.1/ sudo cp *  /lib/firmware/ath10k/QCA6174/hw2.1/ cd /lib/firmware/ath10k/QCA6174/hw2.1/ sudo mv firmware-5.bin_SW_RM.1.1.1-00157-QCARMSWPZ-1  firmware-5.bin    

Reinicie e deixe-nos ver novamente:

  dmesg | grep ath    
 

Let's try different firmware. With a working internet connection by ethernet, tethered or whatever means possible, open a terminal and do:

sudo apt-get update sudo apt-get install git git clone https://github.com/kvalo/ath10k-firmware.git cd ath10k-firmware/QCA6174/hw2.1/ sudo cp *  /lib/firmware/ath10k/QCA6174/hw2.1/ cd /lib/firmware/ath10k/QCA6174/hw2.1/ sudo mv firmware-5.bin_SW_RM.1.1.1-00157-QCARMSWPZ-1  firmware-5.bin 

Reboot and let us see again:

dmesg | grep ath 
 
 
 
 

Perguntas relacionadas

1  LED sem fio não pára de piscar em um HP DV5 com um atheros ar5007  ( Wireless led doesnt stop blinking on an hp dv5 with an atheros ar5007 ) 
Então, estou tendo esse problema com o led wifi que não pare de piscar quando estou usando a internet. Eu tentei muitas soluções diferentes. Eu procurei mui...

3  Não sem fio depois de retomar de suspender?  ( No wireless after resuming from suspend ) 
Quando eu retomar meu computador do suspenso, não deseja se conectar a nenhuma conexão sem fio. Parece que está se conectando, mas depois de um tempo, me pede...

2  Ubuntu WiFi mais de 40 vezes mais lento que os drivers FreeBSD e Windows  ( Ubuntu wifi over 40 times slower than freebsd and windows drivers ) 
O que dá com o horrível suporte WiFi do Ubuntu? ~$ uname -a Linux CQF-MSI 4.13.0-37-generic #42~16.04.1-Ubuntu SMP Wed Mar 7 16:03:28 UTC 2018 x86_64 x86_...

6  Atheros ar2413 não funciona após a atualização [FECHADO]  ( Atheros ar2413 not working after upgrade ) 
. FECHADO. Esta questão é off-tópico . Atualmente não está aceitando respostas. Quer melh...

1  O dispositivo Ath10K Wifi não funciona - Carga de firmware falhou (QCA9377)  ( Ath10k wifi device doesnt work firmware load failed qca9377 ) 
Eu estou em 17.04 em um novo laptop que tem um QCA9377 e é uma dor no **. Eu encontrei diferentes métodos on-line, como o repo Git de kvalo ou reinstalando ...

0  Cartão sem fio faz com que o Ubuntu 12.04 congele na inicialização  ( Wireless card causes ubuntu 12 04 to freeze on startup ) 
Atualmente estou executando o Ubuntu 12.04 64-bit com uma placa sem fio TP-link TL-WN851ND. Toda vez que eu inicio, em qualquer lugar entre 0 e 60 segundos ap...

6  Problemas com a Qualcomm Atheros QCA6174 no Ubuntu 16.04  ( Problems with qualcomm atheros qca6174 in ubuntu 16 04 ) 
Eu comprei recentemente um laptop Acer Aspire R5-471T e instalei o Ubuntu 16.04, mas não consigo conseguir o trabalho sem fio. De acordo com meu Google-Fu, is...

9  Existe alguma maneira de instalar os drivers atheros e2400?  ( Is there any way to install atheros e2400 drivers ) 
Eu tenho uma nova placa-mãe: MSI Z170A Gaming M5. Esta placa-mãe possui um controlador Ethernet Atheros Killer E2400. Quando eu faço lspci -nn , eu recebo: ...

2  Sem fio instável com um atheros ar9285  ( Wireless unstable with an atheros ar9285 ) 
Eu tenho um ASUS Eee PC 1001px executando o Ubuntu 12.04. Tudo funciona bem, mas o WiFi é instável. Quando eu inicializo o WiFi funciona bem, mas depois de ce...

3  Congelamento do sistema causado pelo driver Ath9k  ( System freeze caused by ath9k driver ) 
Eu tive esse problema com 10.04, 10.10 , mas eu estava capaz de resolvê-lo por costume compilar o driver de fontes recentes. E eu tive que re-compilar, muito...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.