Sistema apt-get completamente quebrado. possível reinstalá-lo completamente? [fechado] -- apt camp askubuntu Relacionado O problema

Apt-Get system completely broken. possible to completely reinstall it? [closed]


3
vote

problema

português
.

Eu apenas notei recentemente meu sistema apt-get está quebrado. Eu tentei tudo que posso para consertá-lo, mas tudo que me diz que acaba de acabar com uma mensagem dizendo que o sistema apt-get é corrupto e imprudente. Quando tento instalar um pacote, diz que não consegue encontrá-lo. Como posso reinstalar completamente o apt-get? Há ainda assim?

english

I just recently noticed my apt-get system is broken. I have tried everything I can to fix it but everything I'm told just ends up with a message saying that the apt-get system is corrupt and unfixable. When I try to install a package, it says it can't find it. How can I completely reinstall apt-get? Is there even such a thing?

  
   
   

Lista de respostas

3
 
vote
vote
Melhor resposta
 

Você pode baixar pacotes apt do Ubuntu REPOS e instalá-los manualmente.

no começo, crie um diretório em ~/Downloads e vá para ele:

  mkdir ~/Downloads/apt-packs cd ~/Downloads/apt-packs    

e baixe todos os pacotes apt correspondentes à sua arquitetura (AMD64 ou I386). Por exemplo, você tem AMD64 (Ubuntu 64bit):

Download a seguir pacotes Deb para apt (apt e suas dependências):

  wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-inst2.0_1.1.5_amd64.deb wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-pkg5.0_1.1.5_amd64.deb wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-utils_1.1.5_amd64.deb wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.1.5_amd64.deb    

Finalmente, instale todos eles com dpkg :

  sudo dpkg -i *.deb    
 

You can download apt packages from Ubuntu repos and install them manually.

At first, create a directory in ~/Downloads and go into it:

mkdir ~/Downloads/apt-packs cd ~/Downloads/apt-packs 

And then download all apt packages corresponding to your architecture (amd64 or i386). For example, you have amd64 (Ubuntu 64bit):

Download following deb packages for apt (apt and its dependencies):

wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-inst2.0_1.1.5_amd64.deb wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/libapt-pkg5.0_1.1.5_amd64.deb wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-utils_1.1.5_amd64.deb wget http://archive.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.1.5_amd64.deb 

Finally, install them all with dpkg:

sudo dpkg -i *.deb 
 
 
   
   

Perguntas relacionadas

9  Mesclar vários arquivos MP4 em um único vídeo através do terminal [duplicado]  ( Merge multiple mp4 files into a single video via the terminal ) 
. Esta pergunta já tem respostas aqui : O que o software pode participar de vídeos? ...

1  Não é possível instalar o IDE do Lazarus no Ubuntu 10.04  ( Cannot install lazarus ide on ubuntu 10 04 ) 
Eu baixei arquivos * .deb da página inicial do Lázaro e usada sudo dpkg -i *.deb na pasta lábarus. Isso instalou, mas não pôde ser devido ao erro dizen...

1  O sistema caiu, mostrando o terminal 'Configurando a caixa de inicialização segura'  ( System has crashed terminal showing configuring secure boot box ) 
Eu tentei atualizar o XFCE Desktop com - sudo apt-get upgrade xfce4 Por razões desconhecidas, o processo não foi concluído. Depois disso sempre que eu ...

3  Não é possível instalar drivers para o meu cartão WiFi Realtek RTL8723BE no Ubuntu 16.10  ( Cannot install drivers for my realtek rtl8723be wifi card in ubuntu 16 10 ) 
tentou $ sudo add-apt-repository ppa:hanipouspilot/rtlwifi $ sudo apt-get update $ sudo apt-get install rtlwifi-new-dkms linux-firmware mas dar ...

1  Quais são os vários 'anúncios' ou 'avisos' para atualizações de pacotes?  ( What are the various announcements or notices for package updates ) 
Recentemente, me deparei com o USN - Notices de segurança do Ubuntu e a DSA - Debian Security anuncie e descobriu que estas são as listas de email para as atu...

2  Erro ao adicionar um repositório a /etc/apt/sources.list  ( Error adding a repository to etc apt sources list ) 
no Ubuntu 14.04, segui http: //mirror.its. dal.ca/cran/bin/linux/ubuntu/readme que diz Installation and compilation of R or some of its packages may requ...

5  Equivalente à história do yum?  ( Equivalent to yum history ) 
Existe um equivalente a yum history comando no Ubuntu? Estou ciente de que posso apenas olhar para os logs apt, mas estou procurando por algo que irá listá-...

1  Gnome-Software Manager ficando em RAM quando fechado xubuntu 16.04  ( Gnome software manager staying in ram when closed xubuntu 16 04 ) 
Vou executar gnome-software 3.20.1 e feche o programa. No entanto, o processo do programa não fecha e ocupa um pedaço notável de memória. O programa também ...

1  / usr / local / bin / bower: Nenhum arquivo ou diretório após reinstalar o Node.js e bower  ( Usr local bin bower no such file or directory after reinstalling node js and b ) 
Eu reinstalei nodejs ( node , npm ) por causa de uma antiga configuração corrompida. Do que eu instalei bower $sudo npm install -g bower /usr/bin/bowe...

0  Apt "conexão falhou"  ( Apt connection failed ) 
Desde a instalação do Ubuntu, não consegui instalar novos pacotes, ele ainda não foi atualizado. Abaixo está uma despejo de erro de conexão que vejo quando te...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.