Sem fio não está funcionando depois de instalar o kernel 4.0.5 no Ubuntu 15.04 -- wireless camp askubuntu Relacionado O problema

Wireless not working after installing Kernel 4.0.5 on Ubuntu 15.04


3
vote

problema

português

Eu só segui isso guia

Qual deve ser a coisa certa a fazer? Reverter para o velho kernel?

  • Aqui está o Log pelo caminho

  • Isso é Acer V5-552G pela maneira como Ussing AMD A-105757M CPU.

Quando eu faço:

  $ sudo modprobe wl    

resultado é:

  modprobe: FATAL: Module wl not found.    

Quando eu executo isso:

  $ sudo apt-get install bcmwl-kernel-source   Reading package lists... Done Building dependency tree        Reading state information... Done bcmwl-kernel-source is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.    

editar: apenas revertido para o kernel 3.19 e eu recebi isto:

  $ lspci -nn | grep 0280   04:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]    
english

I just followed this guide

What should be the right thing to do? Revert to old kernel?

  • Here's the log by the way

  • This is Acer V5-552G by the way ussing AMD A-105757M CPU.

When I do:

$ sudo modprobe wl 

Result is:

modprobe: FATAL: Module wl not found. 

When I run this:

$ sudo apt-get install bcmwl-kernel-source   Reading package lists... Done Building dependency tree        Reading state information... Done bcmwl-kernel-source is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

Edit: Just reverted back to Kernel 3.19 and I got this:

$ lspci -nn | grep 0280   04:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359] 
  
     
     

Lista de respostas

2
 
vote
vote
Melhor resposta
 

Seu dispositivo requer o BCMWL-Kernel-Source.A versão nos repositórios não constrói corretamente para kernels 4.0 e posterior, como você viu. Com uma conexão de internet temporária, abra um terminal e faça:

  sudo apt-get remove bcmwl-kernel-source sudo apt-get install git-buildpackage mkdir bcmwl-ubuntu cd bcmwl-ubuntu git clone https://github.com/longsleep/bcmwl-ubuntu.git bcmwl-ubuntu-master cd bcmwl-ubuntu-master gbp buildpackage -b -uc -us sudo dpkg -i ../bcmwl-kernel-source_6.30.223.248+bdcom-longsleep0_amd64.deb    

O módulo do kernel será construído automaticamente para todo o seu kernel instalado versões com a ajuda de DKMS e aplicar corrigão conforme necessário.

Reiniciar e seu wireless deve estar funcionando.

 

Your device requires bcmwl-kernel-source.The version in the repositories doesn't build correctly for kernels 4.0 and later, as you've seen. With a temporary working internet connection, open a terminal and do:

sudo apt-get remove bcmwl-kernel-source sudo apt-get install git-buildpackage mkdir bcmwl-ubuntu cd bcmwl-ubuntu git clone https://github.com/longsleep/bcmwl-ubuntu.git bcmwl-ubuntu-master cd bcmwl-ubuntu-master gbp buildpackage -b -uc -us sudo dpkg -i ../bcmwl-kernel-source_6.30.223.248+bdcom-longsleep0_amd64.deb 

The kernel module will build automatically for all your installed kernel versions with the help of DKMS and apply patching as required.

Reboot and your wireless should be working.

 
 
         
         
2
 
vote

menos dor de cabeça agora como eu tenho pacotes PPA / pré-construídos de https: // launchpad .NET / ~ Longsleep / + Archive / Ubuntu / bcmwl .

Tão fácil de instalar :)

  /dev/sda40   
 

Less headache now as I got PPA/pre-built packages from https://launchpad.net/~longsleep/+archive/ubuntu/bcmwl.

So easy to install :)

sudo apt-get remove bcmwl-kernel-source sudo add-apt-repository ppa:longsleep/bcmwl sudo apt-get update sudo apt-get install bcmwl-kernel-source 
 
 
0
 
vote

Para instalar o novo /dev/sda41 kernel, abra uma janela de terminal e digite em:

/dev/sda42

Depois de instalado, reinicie seu sistema pressionando o deslocamento e selecione opções avançadas de inicialização e selecione o kernel 3.19.x-xx. Uma vez inicializado, você pode remover o kernel 4.0.x digitando o seguinte a partir de uma janela de terminal:

/dev/sda43

Quando remove o kernel 4.0.x, ele deve executar a atualização do grub por conta própria, portanto, quando você reiniciar, ele deve inicializar apenas para o kernel 3.19.x-xx.

Para instalar os kernels 4.0.x, geralmente é melhor obtê-los daqui:

http://kernel.ubuntu.com/~kernel-ppa/mainline/ < / a>

Então, quando quiser instalá-los, abra uma janela de terminal. Vá para a sua pasta / TMP, em seguida, execute /dev/sda44 para baixá-los.

/dev/sda45

Ao baixá-los, escolha os cabeçalhos genéricos, cabeçalhos, e imagem genérica. Eu postei os nomes abaixo:

 Linux-cabeçalhos-4.0.5-040005-generic_4.0.5-040005.201506061639_amd64.deb Linux-cabeçalhos-4.0.5-040005_4.0.5-040005.201506061639_all.deb Linux-Image-4.0.5-040005-generic_4.0.5-040005.201506061639_amd64.deb  

Depois de ser baixado, a partir da pasta / tmp, tudo o que você precisa digitar para instalá-los é

/dev/sda46

Dessa forma, você também mantém o seu kernel 3.19.x-xx instalado também para que você possa cair de volta se o kernel 4.0.5 falhar de alguma forma.

 

To install the older vivid kernel, open a terminal window and type in:

sudo apt-get install --install-recommends linux-generic-lts-vivid

after it is installed, reboot your system by holding down shift, then select advanced boot options, and select the 3.19.x-xx kernel. Once booted in, you can remove the 4.0.x kernel by typing in the following from a terminal window:

sudo apt-get remove linux-headers-4.0* linux-image-4.0*

when it removes the 4.0.x kernel, it should run the grub-update on its own, so when you reboot, it should only boot to the 3.19.x-xx kernel.

To install the 4.0.x kernels, it is usually best to get them from here:

http://kernel.ubuntu.com/~kernel-ppa/mainline/

then when you want to install them, open a terminal window. Go to your /tmp folder, then run wget to download them.

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/name_of_kernel.deb

when downloading them, choose the headers generic, headers all, and image generic. I have posted the names below:

 linux-headers-4.0.5-040005-generic_4.0.5-040005.201506061639_amd64.deb linux-headers-4.0.5-040005_4.0.5-040005.201506061639_all.deb linux-image-4.0.5-040005-generic_4.0.5-040005.201506061639_amd64.deb 

once they are downloaded, from the /tmp folder, all you have to type in to install them is

sudo dpkg -i linux-*.deb

that way you also keep your 3.19.x-xx kernel installed as well so that you can fall back on it if the 4.0.5 kernel fails somehow.

 
 
         
         

Perguntas relacionadas

0  Cartão sem fio faz com que o Ubuntu 12.04 congele na inicialização  ( Wireless card causes ubuntu 12 04 to freeze on startup ) 
Atualmente estou executando o Ubuntu 12.04 64-bit com uma placa sem fio TP-link TL-WN851ND. Toda vez que eu inicio, em qualquer lugar entre 0 e 60 segundos ap...

1  Não é possível conectar-se ao repetidor de Wi-Fi ASUS no Ubuntu  ( Cant connect to asus wi fi repeater in ubuntu ) 
Então, adquiri recentemente um repetidor sem fio (ASUS RP-AC55) porque meu roteador não chegou a todos os lugares que precisava, mas até agora ele introduziu ...

1  Não é possível conectar-se à rede sem fio com um cartão WLAN Broadcom BCM4311 802.11b / g  ( Cannot connect to wireless network with a broadcom bcm4311 802 11b g wlan card ) 
Eu instalei o Ubuntu no meu antigo HP. É a versão 11.10. Não consigo descobrir como conectá-lo à minha rede sem fio. Eu não consigo nem conseguir para digital...

3  Instalando o driver para Netgear WNA1100 WiFi Adapter - Ubuntu Server 12.04  ( Installing driver for netgear wna1100 wifi adapter ubuntu server 12 04 ) 
Eu comprei recentemente o adaptador WIFI WIM1100 para a caixa do Ubuntu Server 12.04. Desde que sou novo no Ubuntu, não consigo instalar os drivers para o ada...

1  Wifi driver não encontrado!  ( Wifi driver not found ) 
Estou executando o Ubuntu 14.10 no HP Pavilion P045TX Dual Booting com o Windows 8.1. Drivers WiFi não são encontrados. Como faço para instalar os drivers par...

1  Broadcom BCM4313 funciona mal em um pavilhão HP G4-1212TU  ( Broadcom bcm4313 works poorly on a hp pavilion g4 1212tu ) 
Acabei de comprar um laptop HP Pavilion G4-1212TU e coloquei Ubuntu 11.10 nele. WiFi funciona mal. Normalmente pode se conectar (embora mostrando um nível de ...

9  REALTEK RTL8188CE driver sem fio instável no ubuntu 14.04  ( Realtek rtl8188ce wireless driver unstable in ubuntu 14 04 ) 
Desde uma nova instalação do Ubuntu 14.04 eu estou perdendo a conexão com a Internet após alguns minutos. Eu volto depois de reiniciar ou despertar do modo de...

3  Não é possível instalar drivers para o meu cartão WiFi Realtek RTL8723BE no Ubuntu 16.10  ( Cannot install drivers for my realtek rtl8723be wifi card in ubuntu 16 10 ) 
tentou $ sudo add-apt-repository ppa:hanipouspilot/rtlwifi $ sudo apt-get update $ sudo apt-get install rtlwifi-new-dkms linux-firmware mas dar ...

1  Auto reconectar ao Wi-Fi  ( Auto reconnect to wi fi ) 
Quando abro meu laptop, leva cerca de 5 segundos para se reconectar à rede Wi-Fi. Existe uma maneira de uma conexão mais rápida? Talvez configure-o para não d...

3  Instala nova de 14.04 - agora incapaz de se conectar ao ponto de acesso UNIFI (outros funcionam)  ( Fresh install of 14 04 now unable to connect to unifi access point others wor ) 
Depois de instalar 14.04, não pode mais se conectar ao meu ponto de acesso UNIFI (trabalhado em 13,10 e funciona a partir do Windows na máquina de inicializaç...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.