CheckInstall não instalando o pacote Debian -- package-management campo com checkinstall camp askubuntu Relacionado O problema

checkinstall failing to install debian package


2
vote

problema

português

Estou tentando instalar o SIP para PYQT e tentar obter o checkinstall para funcionar. Mas continua dizendo

      Installing Debian package... FAILED!    

É isso que está no arquivo de log:

      (Reading database ... 191312 files and directories currently installed.)     Preparing to unpack .../sip_4.16.3-1_amd64.deb ...     Unpacking sip (4.16.3-1) ...     dpkg: error processing archive /home/user/sip-4.16.3/sip_4.16.3-1_amd64.deb (--install):     trying to overwrite '/usr/include/python2.7/sip.h', which is also in package python-sip-dev 4.15.5-1build1     dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)     Errors were encountered while processing: /home/user/sip-4.16.3/sip_4.16.3-1_amd64.deb    

Alguém sabe como posso consertar isso e fazer isso funcionar? Não consigo encontrar nada sobre o que fazer para consertar isso .. Parece que o SIP foi instalado com sucesso - como posso verificar o número da versão.

Também parece ser um arquivo DEB na pasta SIP-4.16.3. Mas quando tento instalar ou remover, recebo

      dpkg: error processing archive sip_4.16.3-1_amd64.deb (--install):     trying to overwrite '/usr/include/python2.7/sip.h', which is also in package python-sip-dev 4.15.5-1build1     dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)     Errors were encountered while processing: sip_4.16.3-1_amd64.deb    
english

I'm trying to install sip for pyqt and trying to get checkinstall to work. But it keeps saying

    Installing Debian package... FAILED! 

This is what's in the log file:

    (Reading database ... 191312 files and directories currently installed.)     Preparing to unpack .../sip_4.16.3-1_amd64.deb ...     Unpacking sip (4.16.3-1) ...     dpkg: error processing archive /home/user/sip-4.16.3/sip_4.16.3-1_amd64.deb (--install):     trying to overwrite '/usr/include/python2.7/sip.h', which is also in package python-sip-dev 4.15.5-1build1     dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)     Errors were encountered while processing: /home/user/sip-4.16.3/sip_4.16.3-1_amd64.deb 

Anyone know how I can fix this and get it to work? I can't find anything on what to do to fix this.. It looks like sip was installed successfully - as I can check the version number.

There also seems to be a deb file in the sip-4.16.3 folder. But when I try to install or remove, I get

    dpkg: error processing archive sip_4.16.3-1_amd64.deb (--install):     trying to overwrite '/usr/include/python2.7/sip.h', which is also in package python-sip-dev 4.15.5-1build1     dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)     Errors were encountered while processing: sip_4.16.3-1_amd64.deb 
     

Lista de respostas

0
 
vote
vote
Melhor resposta
 

Você já tem SIP instalado.

Sua mensagem de erro diz que o arquivo /usr/include/python2.7/sip.h já existe, e faz parte do arquivo python-sip-dev .

Você pode consertar isso de duas maneiras:

    .
  1. desinstalar python-sip-dev usando sudo apt-get uninstall .
  2. Não faça nada.
 

You already have SIP installed.

Your error message says that the file /usr/include/python2.7/sip.h already exists, and is part of the python-sip-dev file.

You can fix this in two ways:

  1. Uninstall python-sip-dev using sudo apt-get uninstall.
  2. Do nothing.
 
 

Perguntas relacionadas

2  Melhor prática para atualizar um software que foi instalado via `checkinstall`  ( Best practice for updating a software that was installed via checkinstall ) 
Uma das práticas recomendadas para instalar um software da origem é usar checkinstall porque é mais fácil remover o software mais tarde. Mas qual é a melh...

34  Compilando a fonte em um pacote de Deb  ( Compiling source into a deb package ) 
Eu sempre tive um problema de instalação e remoção de software compilado, então eu decidi que gostaria de construir software da fonte em um pacote .deb para f...

0  Como faço para resolver esse erro com o CheckInstall: *** [Makefile: 350: Install-recursive] Erro 1  ( How do i solve this error with checkinstall makefile350 install recursiv ) 
Estou tentando instalar o emulador de Desmume e eu venho em erro. Quando uso sudo checkinstall esta é a saída: This software is released under...

0  Sinalização apt eu construímos a partir de uma versão mais recente do pacote existente  ( Signaling apt i have built from source a newer version of existing package ) 
Eu instalei corretamente a partir de uma versão atualizada da Biblioteca PointCloud (libpcl1.9.1), mas não consigo ter links corretamente descobrir em um Cmak...

1  CheckInstall + links simbólicos  ( Checkinstall symbolic links ) 
Eu estou tentando empacotar este código com checkinstall, mas correr em este bug que impede todos os links simbólicos para bibliotecas compartilhadas para...

4  Revertendo problemas causados ​​por checkinstall com a construção do GCC  ( Reverting problems caused by checkinstall with gcc build ) 
Recentemente baixei a fonte GCC 4.6.2 para reproduzir um pouco com C ++ 11. Tendo sido dito sobre CheckInstall e sua utilidade na instalação de programas da...

8  CheckItTall pedindo versão  ( Checkinstall asking for version ) 
Eu tenho um projeto AutoConf / Automático / Autoverything que estou instalando com o checkinstall. Quando eu for para instalá-lo, eu sou mostrado este This...

0  Pacote de CheckInstall .Deb não crie diretórios vazios  ( Checkinstall deb package not create empty directories ) 
Estou tentando criar um pacote .deb para a minha instalação do Xymon-Client, mas não está criando os diretórios vazios usados ​​para logs e arquivos temp. S...

2  CheckInstall não instalando o pacote Debian  ( Checkinstall failing to install debian package ) 
Estou tentando instalar o SIP para PYQT e tentar obter o checkinstall para funcionar. Mas continua dizendo Installing Debian package... FAILED! É i...

4  Build .deb pacote da fonte, sem instalá-lo  ( Build deb package from source without installing it ) 
Suponha que eu tenha um programa de instalador ou tarball de origem para algum programa que eu quero instalar. (Não há nenhum pacote debian disponível.) Prime...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.