Atualização da Biblioteca Nativa de Tomcat -- tomcat camp askubuntu Relacionado O problema

Tomcat native library update


2
vote

problema

português

Eu não posso me livrar de

  An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30    

na ideia do intellij. Acho que só preciso atualizar isso.

  sudo apt-get upgrade libtcnative-1    

não corrigi o problema. diz

.

listas de pacotes de leitura ... Feito Construindo Leitura de Árvore Dependência Informações do Estado ... Feito Calculando Upgrade ... FEITO libtcnative-1 é já a versão mais recente. 0 atualizado, 0 recentemente instalado, 0 para remover e 0 não atualizado.

erro do log da ideia:

  /home/ivan/Documents/Tomcat/apache-tomcat-7.0.55/bin/catalina.sh run Connected to the target VM, address: '127.0.0.1:60749', transport: 'socket' [2014-09-23 02:11:57,027] Artifact perc-web:war exploded: Server is not connected. Deploy is not available. Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["http-bio-8080"] Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["ajp-bio-42919"] Sep 23, 2014 2:11:58 AM org.apache.catalina.startup.Catalina load INFO: Initialization processed in 983 ms Sep 23, 2014 2:11:58 AM org.apache.catalina.core.StandardService startInternal INFO: Starting service Catalina Sep 23, 2014 2:11:58 AM org.apache.catalina.core.StandardEngine startInternal INFO: Starting Servlet Engine: Apache Tomcat/7.0.55 Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["http-bio-8080"] Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["ajp-bio-42919"] Sep 23, 2014 2:11:58 AM org.apache.catalina.startup.Catalina start INFO: Server startup in 64 ms Connected to server [2014-09-23 02:11:59,386] Artifact perc-web:war exploded: Artifact is being deployed, please wait... OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000000f6480000, 88604672, 0) failed; error='Cannot allocate memory' (errno=12) # # There is insufficient memory for the Java Runtime Environment to continue. # Native memory allocation (malloc) failed to allocate 88604672 bytes for committing reserved memory. # An error report file with more information is saved as: # /home/ivan/Documents/Tomcat/apache-tomcat-7.0.55/bin/hs_err_pid18653.log Disconnected from the target VM, address: '127.0.0.1:60749', transport: 'socket' Disconnected from server [2014-09-23 02:12:04,177] Artifact perc-web:war exploded: Error during artifact deployment. See server log for details.    
english

I can't get rid of

An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 

in Intellij Idea. I think I just need to update that.

sudo apt-get upgrade libtcnative-1 

didn't fix the problem. it says

Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done libtcnative-1 is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Error from Idea log:

/home/ivan/Documents/Tomcat/apache-tomcat-7.0.55/bin/catalina.sh run Connected to the target VM, address: '127.0.0.1:60749', transport: 'socket' [2014-09-23 02:11:57,027] Artifact perc-web:war exploded: Server is not connected. Deploy is not available. Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.catalina.core.AprLifecycleListener init SEVERE: An incompatible version 1.1.29 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.30 APR Statistical data .... Poll Statistics ......... Polls created           : 0 Polls destroyed         : 0 Polls cleared           : 0 Network Statistics ...... Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 Total send calls        : 0 Minimum send length     : 10000000 Maximum send length     : 0 Average send length     : -nan Total recv calls        : 0 Minimum recv length     : 10000000 Maximum recv length     : 0 Average recv length     : -nan Receive timeouts        : 0 Receive errors          : 0 Receive resets          : 0 Last receive error      : 0 Total sendfile calls    : 0 Minimum sendfile length : 10000000 Maximum sendfile length : 0 SSL Network Statistics .. Sockets created         : 0 Sockets accepted        : 0 Sockets closed          : 0 Sockets cleared         : 0 APR Terminated Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["http-bio-8080"] Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["ajp-bio-42919"] Sep 23, 2014 2:11:58 AM org.apache.catalina.startup.Catalina load INFO: Initialization processed in 983 ms Sep 23, 2014 2:11:58 AM org.apache.catalina.core.StandardService startInternal INFO: Starting service Catalina Sep 23, 2014 2:11:58 AM org.apache.catalina.core.StandardEngine startInternal INFO: Starting Servlet Engine: Apache Tomcat/7.0.55 Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["http-bio-8080"] Sep 23, 2014 2:11:58 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["ajp-bio-42919"] Sep 23, 2014 2:11:58 AM org.apache.catalina.startup.Catalina start INFO: Server startup in 64 ms Connected to server [2014-09-23 02:11:59,386] Artifact perc-web:war exploded: Artifact is being deployed, please wait... OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000000f6480000, 88604672, 0) failed; error='Cannot allocate memory' (errno=12) # # There is insufficient memory for the Java Runtime Environment to continue. # Native memory allocation (malloc) failed to allocate 88604672 bytes for committing reserved memory. # An error report file with more information is saved as: # /home/ivan/Documents/Tomcat/apache-tomcat-7.0.55/bin/hs_err_pid18653.log Disconnected from the target VM, address: '127.0.0.1:60749', transport: 'socket' Disconnected from server [2014-09-23 02:12:04,177] Artifact perc-web:war exploded: Error during artifact deployment. See server log for details. 
  
   
   

Lista de respostas

3
 
vote
vote
Melhor resposta
 

Tomcat 7.0.55 requer libtcnative-1 1.1.30, mas não há tal pacote disponível a partir dos repositórios padrão.

Eu vi libtcnative 1.1.31 para o Ubuntu 14.04, disponível em https: // launchpad.net/~pharmingkb/+archive/ubuntu/trusty .

Você pode atualizar para ele com:

  > sudo add-apt-repository ppa:pharmgkb/trusty > sudo apt-get update > sudo apt-get upgrade libtcnative-1    
 

Tomcat 7.0.55 requires libtcnative-1 1.1.30, but there's no such package available from the standard repositories.

I've backported libtcnative 1.1.31 for Ubuntu 14.04, available from https://launchpad.net/~pharmgkb/+archive/ubuntu/trusty.

You can upgrade to it with:

> sudo add-apt-repository ppa:pharmgkb/trusty > sudo apt-get update > sudo apt-get upgrade libtcnative-1 
 
 

Perguntas relacionadas

9  Instale uma versão diferente de um pacote  ( Install a different version of a package ) 
Estou executando o Lucid Server e instalei o Tomcat. A versão instalada é 6.0.24-2ubuntu1.6. Esta é a versão que estou amarrada? É possível instalar uma ver...

0  Tomcat: usuários e papéis  ( Tomcat users and roles ) 
Na documentação de Tomcat9 diz que você pode configurar usuários em: /tomcatinstallationdolder/conf/tomcat-users.xml <tomcat-users xsi:schemaLocation="http...

4  Existe uma maneira que eu possa instalar o Tomcat7 no Ubuntu 18.04?  ( Is there a way i can install tomcat7 on ubuntu 18 04 ) 
Eu gostaria de instalar o Tomcat7 (não Tomcat8) no Ubuntu 18.04. Eu percebi que poderia permitir o repo do universo fazendo o seguinte sudo add-apt-reposit...

2  Tomcat6 Manager  ( Tomcat6 manager ) 
Acabei de instalar o Ubuntu 10.04 Lts Server com suporte à lâmpada. Tomcat6 parece funcionar bem. Mas eu não consigo entrar no gerente-webapp ... Eu atualizei...

2  Como começar o Tomcat7 quando Catalina.sh não funciona?  ( How to start tomcat7 when catalina sh does not work ) 
Eu instalei o Tomcat7 através do comando sudo apt-get install tomcat7 , Agora eu fui para /usr/share/tomcat7/bin e introduzido catalina.sh mas o seguinte...

3  Atualizar para o mais recente Tomcat / JRE ou Stick com o que é fornecido por LTS?  ( Upgrade to latest tomcat jre or stick with whats provided by lts ) 
Executando um servidor Web de produção com o Ubuntu 12.04, que é enviado Tomcat 7.0.26. Devo me importar em atualizar a instalação do Tomcat para a última ver...

0  Instalando o Tomcat no Ubuntu  ( Installing tomcat in ubuntu ) 
Eu faço download do apache-tomcat-x.x.x.tar.gz do apache. Eu extraí e defini o Catalina_Home. Deram permissão para todo o arquivo SH para o bin. Ao executar o...

1  Instalando o Eclipse 3.6 e o ​​Tomcat 7  ( Installing eclipse 3 6 and tomcat 7 ) 
Eu sou um iniciante com o Ubuntu. Eu li muitas perguntas, mas não consegui descobrir como instalar o Eclipse 3.6 e o ​​Tomcat 7 no Ubuntu 11.04. Eu tentei mui...

0  Como parar o servidor Tomcat6?  ( How to stop the tomcat6 server ) 
Eu estou usando o Ubuntu. Mesmo quando tento parar o Tomcat, ele continua correndo. Por exemplo: sudo /etc/init.d/tomcat6 stop O acima não o impede, ap...

5  Instalação de Tomcat Startup.sh não funciona  ( Tomcat installation startup sh not working ) 
Então eu segui a lista de passos em: https://www.digitalocean.com/community/articles/how-to-install-apache-tomcat-on-ubuntu-12-04 . Quando tento executar o...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.