Instale o SopCast em 64 bits -- apt camp askubuntu Relacionado O problema

Install Sopcast in 64-bits


3
vote

problema

português

Eu sou um novo usuário do Ubuntu e estou encontrando muitas dificuldades para instalar o Sopcat

Eu usei o seguinte código:

  sudo add-apt-repository ppa:ferramroberto/sopcast sudo apt-get update sudo apt-get install sopcast-player    

Após o último comando, eu tive a seguinte resposta

  The following packages have unmet dependencies. sopcast-player : Depends: sp-auth (>= 3.0.1) but it is not installable E: Unable to correct problems, you have held broken packages.    

Eu goodi o problema e descobri que tenho que instalar o pacote sp-auth_3.2.6.1 ~ lffl ~ natty ~ ppa_i386.deb em https://launchpad.net/~ferramroberto/+arramRoberto/+chive/sopcast/+Build/2405344

mas quando tento instalar, aparece no meu centro de software "Arquitecura errada 'I386'"

Alguma sugestão?

english

I'm a new user of Ubuntu and I'm finding a lot of difficulties installing Sopcat

I used the following code:

sudo add-apt-repository ppa:ferramroberto/sopcast sudo apt-get update sudo apt-get install sopcast-player 

After the last command, I had the following answer

The following packages have unmet dependencies. sopcast-player : Depends: sp-auth (>= 3.0.1) but it is not installable E: Unable to correct problems, you have held broken packages. 

I googled the problem and I found out that I have to install the package sp-auth_3.2.6.1~lffl~natty~ppa_i386.deb on https://launchpad.net/~ferramroberto/+archive/sopcast/+build/2405344

But when I try to install it appears in my software center "wrong architechture 'i386' "

Any suggestions?

  
         
         

Lista de respostas

3
 
vote

Eu tive o mesmo problema de instalação sopcast no início, muitos tutoriais na Internet eram apenas perda de tempo. O problema principal foi que o link foi quebrado no Fórum Ubuntu e Launchpad dá erro 404 enquanto clica na página. Fui ao ABCDEFGHIJKLMNABCDEFGHIJKLMN0 Page, mas não houve link de download para 64 bits. Houve um bug arquivado no LaunchPad sobre ABCDEFGHIJKLMNABCDEFGHIJKLMN1 Instalação e nenhum link de download disponível para amd64 arquitetura. Então, o que eu fiz para instalar foi:

  • sudo add-apt-repository PPA: FERRAMROBERTO / SOPCAST ​​( para adicionar o repositório )
  • baixou o pacote SP-AUTH deste site http://www.n00bsonubuntu.net/content/how-to-install-sopcast-on-ubuntu-13-04/
  • Instalado o pacote SP-AUTH, primeiro usando ABCDEFGHIJKLMNABCDEFGHIJKLMN3 . Você pode clicar com o botão direito do mouse e usar ubuntu software centre também.
  • do terminal: sudo apt-get update
  • sudo apt-get install sopcast-player
  • Finalmente para o Firefox reconhecer o sop:// link ( embora não é importante para o mais recente Firefox )
    • na barra de endereços do Firefox, digite about:config e digite a configuração
    • busca por ABCDEFGHIJKLMNABCDEFGHIJKLMN7 e tente alterar o valor para true ou false . No meu caso, trabalhou com sp-auth0 .

Agora estou usando o jogador SOP-CAST

 

I had the same problem installing Sopcast at first, lots of tutorials in internet were just waste of time. The main problem was, the link was broken in Ubuntu forum and launchpad gives 404 error while clicking the page. I went to the femroberto page but there was no download link for 64bit package. There was a bug filed in launchpad about sp-auth installation, and no download link available for amd64 architecture. So, what I did to install was:

  • sudo add-apt-repository ppa:ferramroberto/sopcast (To add the repository)
  • Downloaded the sp-auth package from this website http://www.n00bsonubuntu.net/content/how-to-install-sopcast-on-ubuntu-13-04/
  • Installed the sp-auth package first using gdebi package installer. You can right click and use ubuntu software centre too.
  • From Terminal: sudo apt-get update
  • sudo apt-get install sopcast-player
  • Finally for Firefox to recognise the sop:// link (Though not important for latest firefox)
    • In Firefox address bar, type about:config and Enter the config
    • Search for network.protocol-handler.expose-all and try by changing the value to true or false. In my case it worked with true.

Now I am using sop-cast player

 
 
         
         
3
 
vote

Infelizmente, o PPA não funcionará para raricer (13.04) e para cima. Você precisa da versão da linha de comando. Para 64 bits você precisa instalar primeiro o pacote abcdefghgjklmnabcdefghijklmn11 :

  sp-auth2   

Baixe o binário e descontar:

  sp-auth3   

Agora você pode executá-lo apenas usando:

  sp-auth4   

Se você receber uma mensagem como esta, você não instalou a biblioteca LibstDC ++ 5: i386 no início:

  sp-auth5   

Para usar o programa eu recomendo o uso de este ajudante .

Um simples exemplo de sp-auth6 linha de comando (consulte ABCDEFGHIJKLMNABCDEFGHIJKLMN17 Arquivo de dentro do ABCDEFGHIJKLMNABCDEFGHIJKLMN18 Diretório):

  sp-auth9   

começará a transferir o canal geográfico nacional e poderá jogá-lo na porta 8908 com VLC ou MPlayer, por exemplo, abriu o URL:

  amd640   
 

Sadly, the PPA won't work for Raring (13.04) and up. You need the command line version instead. For 64-bits you need to install first the libstdc++5:i386 package:

sudo apt-get install libstdc++5:i386 

Download the binary and untar it:

wget http://download.easetuner.com/download/sp-auth.tgz tar xf sp-auth.tgz cd sp-auth 

Now you can run it just using:

> ./sp-sc-auth     SC Version: 3.2.6  Build time: 2009-11-09 15:09 Usage: ./sp-sc [-TpI] [-b ipaddr] [-u username:password] [-n out:total] <sop://url> <localport> <playerport> 

If you get a message like this, you didn't installed the libstdc++5:i386 library at the start:

./sp-sc-auth zsh: no such file or directory: ./sp-sc-auth 

To use the program I recommend the use of this helper.

A simple example of sp-sc-auth command line (see README file from inside of sp-auth directory):

./sp-sc-auth sop://broker.sopcast.com:3912/148248 3908 8908  > /dev/null & 

will start to transfer National Geographic channel, and you can play it on the port 8908 with VLC or mplayer for example by open the url:

http://localhost:8908/tv.asf 
 
 
   
   

Perguntas relacionadas

1  O sistema caiu, mostrando o terminal 'Configurando a caixa de inicialização segura'  ( System has crashed terminal showing configuring secure boot box ) 
Eu tentei atualizar o XFCE Desktop com - sudo apt-get upgrade xfce4 Por razões desconhecidas, o processo não foi concluído. Depois disso sempre que eu ...

1  Quais são os vários 'anúncios' ou 'avisos' para atualizações de pacotes?  ( What are the various announcements or notices for package updates ) 
Recentemente, me deparei com o USN - Notices de segurança do Ubuntu e a DSA - Debian Security anuncie e descobriu que estas são as listas de email para as atu...

0  Apt "conexão falhou"  ( Apt connection failed ) 
Desde a instalação do Ubuntu, não consegui instalar novos pacotes, ele ainda não foi atualizado. Abaixo está uma despejo de erro de conexão que vejo quando te...

2  Erro ao adicionar um repositório a /etc/apt/sources.list  ( Error adding a repository to etc apt sources list ) 
no Ubuntu 14.04, segui http: //mirror.its. dal.ca/cran/bin/linux/ubuntu/readme que diz Installation and compilation of R or some of its packages may requ...

9  Mesclar vários arquivos MP4 em um único vídeo através do terminal [duplicado]  ( Merge multiple mp4 files into a single video via the terminal ) 
. Esta pergunta já tem respostas aqui : O que o software pode participar de vídeos? ...

1  / usr / local / bin / bower: Nenhum arquivo ou diretório após reinstalar o Node.js e bower  ( Usr local bin bower no such file or directory after reinstalling node js and b ) 
Eu reinstalei nodejs ( node , npm ) por causa de uma antiga configuração corrompida. Do que eu instalei bower $sudo npm install -g bower /usr/bin/bowe...

1  Não é possível instalar o IDE do Lazarus no Ubuntu 10.04  ( Cannot install lazarus ide on ubuntu 10 04 ) 
Eu baixei arquivos * .deb da página inicial do Lázaro e usada sudo dpkg -i *.deb na pasta lábarus. Isso instalou, mas não pôde ser devido ao erro dizen...

1  Gnome-Software Manager ficando em RAM quando fechado xubuntu 16.04  ( Gnome software manager staying in ram when closed xubuntu 16 04 ) 
Vou executar gnome-software 3.20.1 e feche o programa. No entanto, o processo do programa não fecha e ocupa um pedaço notável de memória. O programa também ...

3  Não é possível instalar drivers para o meu cartão WiFi Realtek RTL8723BE no Ubuntu 16.10  ( Cannot install drivers for my realtek rtl8723be wifi card in ubuntu 16 10 ) 
tentou $ sudo add-apt-repository ppa:hanipouspilot/rtlwifi $ sudo apt-get update $ sudo apt-get install rtlwifi-new-dkms linux-firmware mas dar ...

5  Equivalente à história do yum?  ( Equivalent to yum history ) 
Existe um equivalente a yum history comando no Ubuntu? Estou ciente de que posso apenas olhar para os logs apt, mas estou procurando por algo que irá listá-...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.