Compilando Oggvideotools 0.9 no Ubuntu 12.04 -- piling camp askubuntu Relacionado O problema

Compiling oggvideotools 0.9 on Ubuntu 12.04


1
vote

problema

português

Estou tentando compilar Oggvideotools 0.9 no Ubuntu 12.04 Server (0.8 é no Ubuntu REPOS, mas eu quero a atual versão de 0,9 tronco)

  svn co https://oggvideotools.svn.sourceforge.net/svnroot/oggvideotools oggvideotools cd oggvideotools/trunk ./autogen.sh    

e aqui é o que eu recebo:

  System has changed to run under cmake   -- The C compiler identification is GNU -- The CXX compiler identification is GNU -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Looking for include files HAVE_BZERO_H -- Looking for include files HAVE_BZERO_H - not found. -- Looking for include files HAVE_STDINT_H -- Looking for include files HAVE_STDINT_H - found -- checking for module 'theoradec>=1.1' --   found theoradec, version 1.1.1 -- checking for module 'theoraenc>=1.1' --   found theoraenc, version 1.1.1 -- checking for module 'vorbis>=1.2.3' --   found vorbis, version 1.3.2 -- checking for module 'vorbisenc>=1.2.3' --   found vorbisenc, version 1.3.2 -- checking for module 'ogg>=1.1.0' --   found ogg, version 1.2.2 -- Theora encoder library found -- Theora decoder library found -- Vorbis library found -- Vorbis encoder library found -- ogg library found -- GD library and header found Creating config.h Libraries are: theoraenc;theoradec;ogg;theoradec;ogg;vorbis;m;ogg;vorbisenc;vorbis;m;ogg;ogg;GD_LIBRARY-NOTFOUND CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: GD_INCLUDE    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/src    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/docs    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/scripts GD_LIBRARY     linked by target "oggvideotools" in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/src    

Parece que estou bem instalado todas as dependências..mas stil não compilando.

Você tem os mesmos problemas?

Obrigado.

english

I'm trying to compile oggvideotools 0.9 on Ubuntu 12.04 server (0.8 is in the ubuntu repos, but I want the current 0.9 trunk version)

svn co https://oggvideotools.svn.sourceforge.net/svnroot/oggvideotools oggvideotools cd oggvideotools/trunk ./autogen.sh 

and here is what I get :

System has changed to run under cmake   -- The C compiler identification is GNU -- The CXX compiler identification is GNU -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Looking for include files HAVE_BZERO_H -- Looking for include files HAVE_BZERO_H - not found. -- Looking for include files HAVE_STDINT_H -- Looking for include files HAVE_STDINT_H - found -- checking for module 'theoradec>=1.1' --   found theoradec, version 1.1.1 -- checking for module 'theoraenc>=1.1' --   found theoraenc, version 1.1.1 -- checking for module 'vorbis>=1.2.3' --   found vorbis, version 1.3.2 -- checking for module 'vorbisenc>=1.2.3' --   found vorbisenc, version 1.3.2 -- checking for module 'ogg>=1.1.0' --   found ogg, version 1.2.2 -- Theora encoder library found -- Theora decoder library found -- Vorbis library found -- Vorbis encoder library found -- ogg library found -- GD library and header found Creating config.h Libraries are: theoraenc;theoradec;ogg;theoradec;ogg;vorbis;m;ogg;vorbisenc;vorbis;m;ogg;ogg;GD_LIBRARY-NOTFOUND CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: GD_INCLUDE    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/src    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/docs    used as include directory in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/scripts GD_LIBRARY     linked by target "oggvideotools" in directory /var/www/doc.topcleanpackaging.com/extensions/oggvideotools/trunk/src 

It seems I've well installed all dependencies..but stil not compiling.

Do you have the same issues ?

Thank you.

  

Lista de respostas

3
 
vote
vote
Melhor resposta
 

Eu manei para construí-lo, é assim que fiz isso após o checkout.

  sudo apt-get build-dep oggvideotools ./autogen.sh    

Eu gostaria que eu tivesse aprendido o comando build-dep antes, teria me salvado um monte de programas de compilação. Ele faz o download de todas as dependências que você precisa para construir um pacote.

 

I've maneged to build it, this is how I did it after the checkout.

sudo apt-get build-dep oggvideotools ./autogen.sh 

I wish that I had learned the command build-dep earlier it would have saved me a lot of trouble compiling programs. It downloads all dependencies you need to build a package.

 
 
   
   

Perguntas relacionadas

1  Flashcam não compila - videodev.h não encontrado  ( Flashcam doesnt compile videodev h not found ) 
Eu gostaria de compilar Flashcam 1.4.5 da fonte no Lubuntu 13.04, mas reclama: cc -g -shared -fPIC -o flashcamhook.so flashcamhook.c flashcamhook.c:31:28: ...

1  Não é possível executar o programa no NetBeans 7.3  ( Cant run program in netbeans 7 3 ) 
Eu recentemente instalei o Ubuntu 12.04 e instalei o NetBeans 7.3 (não a versão do Ubuntu, diretamente do site). Estou tentando executar um programa básico de...

1  / usr / bin / ld - não é possível encontrar lib  ( Usr bin ld cannot find lib ) 
Eu estou compilando da fonte e tenho o erro: /usr/bin/ld: cannot find -lct Como corrigi-lo? Obrigado. Eu tentei: sudo apt-get install libxt-dev ...

3  Como instalar cmake, Ccmake da fonte?  ( How to install cmake ccmake from source ) 
Eu segui a primeira resposta para este sudo apt-get install build-essential wget http://www.cmake.org/files/v3.2/cmake-3.5.0-rc2.tar.gz tar xf cmake-3....

2  Serviço de construção de pacotes automatizados  ( Automated package build service ) 
Eu estou usando bacula para backup de meus servidores e clientes, mas as versões da Bacula no repositório oficial são muito antigas. Então eu compilei e insta...

13  Tipo de conversão de código usado em arquivos executáveis ​​Linux  ( Type of code conversion used in linux executable files ) 
Eu quero perguntar que o tipo de codificação é usada para tornar os arquivos executáveis ​​do Linux e. hexadecemal, binário ou qualquer outra coisa. Como é co...

4  Como posso fazer um programa (usando o SDL) construído no trabalho do Ubuntu em outros sistemas?  ( How can i make a program using sdl built on ubuntu work on other systems ) 
Estou escrevendo um programa que usa Openal. Quando eu víncio contra ele (estou usando cmake), também liga a libpulse - pulsosaudio. Isso resulta no binário q...

3  Compilando o VIM-Gnome com suporte a Ruby  ( Compiling vim gnome with ruby support ) 
Eu segui este blog Postar Para compilar GVIM com suporte a Ruby. No entanto, quando eu make , recebo este erro: /usr/bin/ld: cannot find -lruby-static c...

4  Qual é o papel das bibliotecas estáticas?  ( What is the role of static libraries ) 
Bibliotecas estáticas por padrão ao vivo em /usr/lib ou /usr/lib64 mas eu apaguei todos eles no meu sistema operacional com este comando: find / -name ...

5  Posso ligar para um programa .cpp em bash?  ( Can i call a cpp program in bash ) 
Eu sou novo na programação Bash. Eu quero ligar para o meu programa C ++ no arquivo bash. meu programa é myProg.cpp : #include<iostream> using namespace...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.