Como faço para obter Wakeonlan trabalhando quando meu controlador de rede usa o módulo Sky2? -- kernel campo com wakeonlan camp askubuntu Relacionado O problema

How do I get WakeOnLAN working when my network controller uses the sky2 module?


2
vote

problema

português

Eu tenho uma placa-mãe aopen i945gmm-hl. Ainda funciona bem, e o BIOS está definido para permitir que o Wakeonlan ligue a máquina, mas como um sistema operacional recente atualiza esses pacotes mágicos, não funcionando mais.

Aqui está a saída de lspci -v para o NIC:

  03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 22)     Subsystem: AOPEN Inc. Device 0607     Flags: bus master, fast devsel, latency 0, IRQ 43     Memory at fdefc000 (64-bit, non-prefetchable) [size=16K]     I/O ports at ce00 [size=256]     [virtual] Expansion ROM at fdd00000 [disabled] [size=128K]     Capabilities: [48] Power Management version 2     Capabilities: [50] Vital Product Data     Capabilities: [5c] MSI: Enable+ Count=1/2 Maskable- 64bit+     Capabilities: [e0] Express Legacy Endpoint, MSI 00     Capabilities: [100] Advanced Error Reporting     Kernel driver in use: sky2    

RUNNING ver. 3.4.6-1 do kernel.

english

I have an Aopen i945GMM-HL motherboard. It still works fine, and the BIOS is set to allow WakeOnLAN to power up the machine but since a recent OS update those magic packets just don't work anymore.

Here's the output of lspci -v for the NIC:

03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 22)     Subsystem: AOPEN Inc. Device 0607     Flags: bus master, fast devsel, latency 0, IRQ 43     Memory at fdefc000 (64-bit, non-prefetchable) [size=16K]     I/O ports at ce00 [size=256]     [virtual] Expansion ROM at fdd00000 [disabled] [size=128K]     Capabilities: [48] Power Management version 2     Capabilities: [50] Vital Product Data     Capabilities: [5c] MSI: Enable+ Count=1/2 Maskable- 64bit+     Capabilities: [e0] Express Legacy Endpoint, MSI 00     Capabilities: [100] Advanced Error Reporting     Kernel driver in use: sky2 

running ver. 3.4.6-1 of the kernel.

     

Lista de respostas

1
 
vote

As informações abaixo são do OP, pois ele não pode responder sua própria pergunta por mais 7 horas.

A solução para este problema foi bastante simples. Aparentemente de volta quando o kernel que costumava usar foi feito, as opções de gerenciamento de energia nunca foram lidas do BIOS. Tudo o que mudou, mas alguns BIOS relatam seus dados incorretamente, resultando em quebra de alguns recursos de gerenciamento de energia para alguns usuários. Soluções alternativas foram postadas na lista de discussão do Kernel Linux como patches, mas foi decidido adicionar uma opção de módulo.

assim. Se você está tendo dificuldade em ter o Wakeonlan para trabalhar com seu sistema, apesar do Ethtool & Amp; Suas configurações do BIOS dizem, tente colocar isso em um arquivo .conf (por exemplo, Sky2.conf) em /etc/modprobe.d/

  options sky2 legacy_pme=1    

fyi, se descarregar o módulo Sky2 para experimentá-lo com a opção Legacy_pme, certifique-se de definir o Wakeonlan de volta com

  sudo ethtool -s eth0 wol g    

Antes de ligar o sistema,

 

The below information is from the OP, as he can't answer his own question for 7 more hours.

The solution for this problem was quite simple. Apparently back when the kernel I used to use was made, power management options were never read from the BIOS. All that changed, but some BIOSes report their data incorrectly resulting in breakage of some power management features for some users. Workarounds were posted to the Linux Kernel Mailing List as patches but it was decided to add a module option instead.

So. If you're having a hard time getting wakeonlan to work with your system despite what ethtool & your BIOS settings say, try putting this into a .conf file (e.g. sky2.conf) in /etc/modprobe.d/

options sky2 legacy_pme=1 

FYI, if unloading the sky2 module to try it with the legacy_pme option yourself, be sure to set wakeonlan back on with

sudo ethtool -s eth0 wol g 

before powering the system down

 
 
1
 
vote

Eu queria compartilhar algumas informações - isso pode ajudar com o seu problema de wakeonlan (wol) com o dispositivo Marvell.

Eu tenho um dispositivo de transporte com o Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (Rev 12). Eu tenho executado o Ubuntu 10.04 LTS e XBMC, com o driver Sky2 v1.25. Wol correndo bem nesta configuração.

Recentemente tive que atualizar para 12,04 lts como parte de outra história, e corro para o problema wol não funcionando mais com o Sky2 v1.30

O driver Sky2 falha por causa do manuseio de parâmetros de Y2_HW_WOL_ON e Y2_HW_WOL_OFF e o registro escreve, durante o sky2_wol_init função.

Eu não sou de modo algum um desenvolvedor Linux, mas usando uma combinação de lspci e setpci comandos, eu fungei os registros no dispositivo Marvell que foram definidos pelo Driver v1.25 e o driver v1.30, e agora defina o registro manualmente com o SetPCI ao executar o driver V1.30. Wakeonlan trabalha novamente com 12.04 lts e v1.30 driver sem qualquer recompilação!

O registro (no meu sistema) está em ABCDEFGHIJKLMNABCDEFGHIJKLMN5 e precisa de sua configuração de valor para 0x80 . Meu Chip Marvell está no barramento PCI em ABCDEFGHIJKLMNABCDEFGHIJKLMN7 , encontrado usando ABCDEFGHIJKLMNABCDEFGHIJKLMN8 .

Adicionei este comando no mesmo script de inicialização usado para executar a sequência EthTool:

  setpci -s 02:00 41.b=80    

Então, um hack nasty, mas funciona bem. Eu fixaria o driver Y2_HW_WOL_OFF0 se eu soubesse como construir um driver de kernel no meu sistema ...

 

I wanted to share some information - this may help with your wakeonlan (WOL) issue with the Marvell device.

I have a Shuttle device with Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12). I have been running Ubuntu 10.04 LTS and XBMC, with the Sky2 driver v1.25. WOL running just fine in this setup.

I recently had to upgrade to 12.04 LTS as part of another story, and run into the WOL problem not working anymore with Sky2 v1.30

The Sky2 driver fails because of parameter handling of Y2_HW_WOL_ON and Y2_HW_WOL_OFF and the register writes, during the sky2_wol_init function.

I am by no means a Linux developer, but using a combination of lspci and setpci commands, I sniffed out the registers in the Marvell device that were set by the driver v1.25 and the driver v1.30, and now set the register manually with setpci when running the v1.30 driver. Wakeonlan works again with 12.04 LTS and v1.30 driver without any recompiling!

The register (in my system) is at 0x41, and needs its value setting to 0x80. My Marvell chip is on the PCI bus at 02:00.0, found using lspci.

I added this command in the same startup script used to run the ethtool sequence:

setpci -s 02:00 41.b=80 

So, a nasty hack, but works fine. I would fix the sky2.c driver if I knew how to build a kernel driver on my systemxe2x80xa6

 
 

Perguntas relacionadas

2  Wol e modo de sono [fechado]  ( Wol and sleep mode ) 
. Esta questão é improvável que ajude a futuros visitantes; Só é relevante para uma pequena área geográfica, um momento esp...

1  Despertar na porta Configurar LAN  ( Wake on lan configure port ) 
Eu só estava me perguntando se houve uma maneira de alterar a porta que o Wakeonlan está configurado (porta padrão 9)? Estou usando o 64bit ubuntu 13.04. ...

1  Não é possível obter o computador para acordar na LAN  ( Cant get computer to wake on lan ) 
Estou tentando configurar minha área de trabalho (que está funcionando 20.04) para Wol. Eu tentei seguir este guia , Este guia , um monte de outras questões...

2  Ubuntu 18.04 Reiniciando por si mesmo após o desligamento  ( Ubuntu 18 04 restarting by itself after shutdown ) 
Eu sei que já há muitas perguntas aqui relacionadas a este, mas não consigo encontrar uma resposta que resolva o meu problema. Eu instalei um novo Ubuntu 18...

2  Acorda na LAN com Maas preso no comissionamento (não liga a máquina)  ( Wake on lan with maas stuck in commissioning does not turn on the machine ) 
Eu tenho um controlador de cluster de Maas com dois nic ( eth0 - 193.51.236.0/24 - conectado à rede pública e p1p1 - 192.168.0.0/24 - usado para nós de Maa...

4  Nó em maas não acordando na lan  ( Node in maas not waking up on lan ) 
Eu estou tentando adicionar nós no cluster de Maas. Eu configurei o servidor maas na VM usando o Ubuntu 14.04 lts. Eu completei as tarefas pós-instalação, com...

2  Wakeonlan do host remoto  ( Wakeonlan from remote host ) 
Eu tenho configuração wake on lan serviço no meu servidor. Tudo funciona bem na rede local: root@server$: poweroff user@local$ wakeonlan AA:BB:CC:DD:EE:F...

3  Problema com Wakeonlan com Ubuntu 20.04  ( Trouble with wakeonlan with ubuntu 20 04 ) 
Eu segui as instruções sobre https://help.ubuntu.com/community/wakeonlan < / a> Mas estou tendo dificuldade em conseguir funcionando. Meu BIOS está habilitad...

9  Gerenciamento de energia - Sleep / Wake Up Server quando acessado  ( Power management sleep wake up server when accessed ) 
Eu tenho um microsserver hpless HP ProLiant com o Ubuntu instalado. Esta máquina tem compartilhamentos de samba, servindo mídia e eu geralmente RDP ou SSH nel...

1  Como habilitar o Wol no Ubuntu 16.10?  ( How to enable wol on ubuntu 16 10 ) 
Eu configurei o BIOS na minha placa-mãe MSI Z170 com eup2013 desativado Retomar da PCIe Mas eu ainda não consigo fazer o wol no meu trabalho do Ubuntu...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.