O LUBUNTU 12.04 é um lançamento não-LTS - isso significa que o LXDE não é? -- lubuntu campo com desktop-environments campo com lxde campo com release-management camp askubuntu Relacionado O problema

Lubuntu 12.04 is a non-LTS release - does this mean that LXDE isn't, either?


6
vote

problema

português

Lubuntu 12.04 não é uma liberação de suporte a longo prazo. Isso é principalmente devido à falta de mão-de-obra.

Mas eu não uso Lubuntu na minha máquina, eu uso LXDE sobre estoque Ubuntu 12.04 lts. Então minha pergunta é:

Nos próximos cinco anos, haverá atualizações de segurança e correções de bugs para pacotes LXDE, como Openbox, PCManfm e LXSession? Ou o "LTS" em 12.04 lts inclui apenas pacotes de unidade de estoque?

Eu acho que esta questão é tão relevante para qualquer outro de lá fora.

english

Lubuntu 12.04 is not a long-term-support release. That's mostly due to a lack of manpower.

But I don't use Lubuntu on my machine, I use LXDE over stock Ubuntu 12.04 LTS. So my question is:

In the next five years, will there be security updates and bug fixes for LXDE-packages such as Openbox, PCmanFM and LXsession? Or does the "LTS" in 12.04 LTS only include stock Unity packages?

I guess this question is just as relevant for any other DE out there.

           

Lista de respostas

5
 
vote
vote
Melhor resposta
 

Se você olhar para os pacotes LXDE (eu escolhi lxde-comum) você verá:

  Package: lxde-common Priority: optional Section: universe/x11 Installed-Size: 1124 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Original-Maintainer: Debian LXDE Packaging Team <pkg-lxde-maintainers@lists.alioth.debian.org> Architecture: all Version: 0.5.0-4ubuntu3 Depends: lxsession (>= 0.4.4-2) Recommends: lxde-core (>= 0.5.0-4ubuntu3) Suggests: lxlauncher Filename: pool/universe/l/lxde-common/lxde-common_0.5.0-4ubuntu3_all.deb Size: 832896 MD5sum: 800d4f0c55534081334405c74abd2421 SHA1: ad0a5798080e3fbc95b1a039811b1c48b5a8eb41 SHA256: 1e0cd437d89948ada2a02f1360dfa15d0a674e6a9e9e61d87270ac12d7fb15e9 Description-en: the Lightweight X11 Desktop Environment configuration data  LXDE (the Lightweight X11 Desktop Environment) is a project aimed  to provide a new desktop environment which is lightweight and fast.  .  It's not designed to be powerful and bloated, but to be usable and slim  enough, and keep the resource usage low.  Different from other desktop  environments, lxde don't tightly integrate every component. Instead,  lxde tried to make all components independent, and each of them can be  used independently with fewer dependencies.  .  Features:   - Lightweight, runs with reasonable memory usage   - Fast, rund well even on older machines produced in 1999   - Good-looking, GTK+ 2 internationalized user interface   - Easy-to-use, the user interface is simple, but usable enough   - Desktop independent (suprise! Every component can be used without LXDE)   - Standard compliant, follows the specs on freedesktop.org Homepage: http://lxde.org Description-md5: c6b780702af08f256b4707025f34cc99 Bugs: https://bugs.launchpad.net/ubuntu/+filebug Origin: Ubuntu    

A dica que você está procurando é o Section: universe/x11 . Isso informa que o pacote está no universo:

  • Qual é a diferença entre multiverso, universo, restrito e principal ?

Isso significa que é mantido pela comunidade, e como as pessoas que mantêm a LXDE anunciou que não o apoiarão, basicamente, você não pode ser garantido que será suportado por tanto tempo como você precisa.

Se você fizer um apt-cache show unity você verá uma linha que diz:

  Supported: 5y    

Isso significa que o pacote é suportado por canônico para a vida dos LTS.

As coisas no universo, por outro lado, depende do melhor esforço da comunidade, há algo como pacotes de 20k no universo, então não há como realmente dizer quais a comunidade estará interessada em manter e quais serão ignorados . Se Lubuntu disse que eles não estão planejando apoiá-lo por 5 anos, então é provável que eles signifiquem esses pacotes também (embora eu não possa falar por seu projeto).

PCMANFM e OpenBox também estão no universo, então a mesma coisa provavelmente se aplica. Desculpe, não há uma resposta sólida real, mas é difícil fazer garantias sobre o que será apoiado quando é baseado no tempo voluntário das pessoas.

 

If you look at the lxde packages (I chose lxde-common) you'll see:

Package: lxde-common Priority: optional Section: universe/x11 Installed-Size: 1124 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Original-Maintainer: Debian LXDE Packaging Team <pkg-lxde-maintainers@lists.alioth.debian.org> Architecture: all Version: 0.5.0-4ubuntu3 Depends: lxsession (>= 0.4.4-2) Recommends: lxde-core (>= 0.5.0-4ubuntu3) Suggests: lxlauncher Filename: pool/universe/l/lxde-common/lxde-common_0.5.0-4ubuntu3_all.deb Size: 832896 MD5sum: 800d4f0c55534081334405c74abd2421 SHA1: ad0a5798080e3fbc95b1a039811b1c48b5a8eb41 SHA256: 1e0cd437d89948ada2a02f1360dfa15d0a674e6a9e9e61d87270ac12d7fb15e9 Description-en: the Lightweight X11 Desktop Environment configuration data  LXDE (the Lightweight X11 Desktop Environment) is a project aimed  to provide a new desktop environment which is lightweight and fast.  .  It's not designed to be powerful and bloated, but to be usable and slim  enough, and keep the resource usage low.  Different from other desktop  environments, lxde don't tightly integrate every component. Instead,  lxde tried to make all components independent, and each of them can be  used independently with fewer dependencies.  .  Features:   - Lightweight, runs with reasonable memory usage   - Fast, rund well even on older machines produced in 1999   - Good-looking, GTK+ 2 internationalized user interface   - Easy-to-use, the user interface is simple, but usable enough   - Desktop independent (suprise! Every component can be used without LXDE)   - Standard compliant, follows the specs on freedesktop.org Homepage: http://lxde.org Description-md5: c6b780702af08f256b4707025f34cc99 Bugs: https://bugs.launchpad.net/ubuntu/+filebug Origin: Ubuntu 

The hint you're looking for is the Section: universe/x11. This tells you the package is in Universe:

  • What's the difference between multiverse, universe, restricted and main?

This means that it's community-maintained, and since the people who maintain LXDE announced that they won't be supporting it then basically you can't be guaranteed that it will be supported for as long as you need it.

If you do an apt-cache show unity you'll see a line that says:

Supported: 5y 

This means that the package is supported by Canonical for the life of the LTS.

Things in universe, on the other hand, it depends on community best-effort, there's something like 20k packages in universe, so there's no way of really telling which ones the community will be interested in maintaining and which ones will be ignored. If Lubuntu has said they're not planning on supporting it for 5 years then it's likely they mean those packages as well (though I can't speak for their project).

PCmanFM and openbox are also in universe, so the same thing probably applies. Sorry there isn't a real solid answer, but it's hard to make guarantees on what will be supported when it's based on people's volunteer time.

 
 
   
   

Perguntas relacionadas

62  Eu instalei um alfa ou beta, estou atualizado com o lançamento final se eu continuar atualizando?  ( I installed an alpha or beta am i up to date with the final release if i keep u ) 
Eu instalei um Ubuntu Alpha ou beta e tenho mantido o momento. Então, devo presumir que meu sistema se atualizou automaticamente para o próximo alfa ou beta...

142  Como reverter o Ubuntu para uma versão anterior?  ( How to roll back ubuntu to a previous version ) 
Acabei de instalar uma nova versão do Ubuntu e quero revogá-lo para a versão anterior. Como posso fazer isso? É ainda possível? ...

116  Há um problema com uma liberação alfa / beta do Ubuntu, o que devo fazer?  ( Theres an issue with an alpha beta release of ubuntu what should i do ) 
Eu tenho executado lançamentos alfa do Ubuntu por algum tempo agora. Eu continuo correndo em questões - como posso obter estes resolvidos? O que devo fazer qu...

1  Ubuntu 14.04 Trusty Tahr Update? [duplicado]  ( Will ubuntu 14 04 trusty tahr update ) 
. Esta pergunta já tem respostas aqui : Eu instalei um alfa ou beta, estou atualizado com o lançament...

14  Diferenças entre 10,04 e 11.10  ( Differences between 10 04 and 11 10 ) 
Não tenho experiência com o Linux. Eu comprei um livro (guia do iniciante), mas é para 10.04. Devo baixar 10.04 por isso corresponde ao livro ou use 11.10 com...

1  Quais seriam as características diferentes do Ubuntu 15.04?  ( What would be the different features of ubuntu 15 04 ) 
Quais seriam as diferentes características do Ubuntu 15.04 em comparação com lançamentos tão distantes? ...

439  Como faço para atualizar para uma versão mais recente do Ubuntu?  ( How do i upgrade to a newer version of ubuntu ) 
Quais são as diferentes maneiras que posso usar para atualizar o Ubuntu de um lançamento para outro? ...

4  Versões de software de lançamentos LTS e não-LTS sincronizados do Debian  ( Software versions of lts and non lts releases synced from debian ) 
Li que os lançamentos LTS são baseados em testes debian, enquanto as versões não-LTS são baseadas no Debian instável. Dado o longo ciclo de liberação do Debia...

6  Como rastrear a origem de como as atualizações fazem isso na minha máquina do Ubuntu?  ( How to trace the origin of how updates make it into my ubuntu machine ) 
Como faço para encontrar o "histórico comunitário" completo de como as atualizações listadas pelo "atualizador de software" chegaram à minha máquina Ubuntu? ...

452  Como instalar o software ou atualizar de uma versão antiga não suportada?  ( How to install software or upgrade from an old unsupported release ) 
Recentemente, instalei uma versão mais antiga do Ubuntu na minha velha máquina. Sempre que tento instalar qualquer software, recebo um erro dizendo que não po...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.