12.10 Nenhum áudio via HDMI e Vídeo acelera -- video campo com 12.10 campo com hdmi camp askubuntu Relacionado O problema

12.10 no audio via hdmi and video speeds up


2
vote

problema

português

Eu tenho um laptop com um ATI Radeon 4200, em 12.04 Tudo funcionou bem, desde que atualiza para 12.10 não consigo ficar com som sobre o HDMI. Quando alterno para o áudio HDMI, as velocidades de vídeo até cerca de 2x. Eu posso usar os alto-falantes no meu laptop e assistir a vídeo via HDMI sem problemas.

coisas que tentei:

  • Vários tutoriais para instalar os drivers AMD / ATI, todos os que resultaram em baixo modo gráfico.

  • verificou a saída de cat /proc/asound/cards parece normal

Quando eu inicialmente atualizado houve uma infinidade de problemas que eu acredito que foram devidos ao antigo motorista proprietário ainda sendo usado, mas não compatível, depois de algumas horas tentando consertar que eu decidi fazer uma nova instalação que Funciona muito bem, exceto pelo problema indicado acima. Qualquer ajuda seria muito apreciada !!

Por fim, espero que isso ainda não tenha sido respondido, tentei algumas pesquisas diferentes nas placas e não inventamos nada.

  $ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]  Subdevices: 1/1  Subdevice #0: subdevice #0 card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]  Subdevices: 0/1  Subdevice #0: subdevice #0     
english

I have a laptop with an ati radeon 4200, on 12.04 everything worked fine, since upgrading to 12.10 I cannot get sound over the hdmi. When I switch to hdmi audio the video speeds up to about 2x. I can use the speakers in my laptop and watch video via hdmi with no problems.

Things I have tried:

  • Various tutorials to install the AMD/ATI drivers, all of which resulted in low graphics mode.
  • Checked that everything is properly set in alsamixer, the sound utility and - installed pavucontrol and checked everything in there.
  • Verified the output from cat /proc/asound/cards looks normal

When I initially upgraded there was a plethora of problems which I believe were due to the old proprietary driver still being used but not compatible, after a few hours trying to fix that I decided just to back up and do a fresh install which works great except for the above stated problem. Any help would be greatly appreciated!!

Finally hopefully this hasn't already been answered, I have tried a few different searches on the boards and haven't come up with anything.

$ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]  Subdevices: 1/1  Subdevice #0: subdevice #0 card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]  Subdevices: 0/1  Subdevice #0: subdevice #0  
        
   
   

Lista de respostas

2
 
vote

Eu resolvi este problema! : D. O que eu disse no meu primeiro post estava correto. O som HDMI não funciona com gálio 0.4. Os novos drivers ATI não funcionam para placas gráficas "antigas", como o Radeon 4200.

A solução para este problema é descrita aqui: http://www.ubunuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

A solução envolve a instalação de pacotes não oficiais. Eu tentei e funcionou para mim!

elogios!

 

I solved this problem! :D What I said in my first post was correct. HDMI sound doesn't work with Gallium 0.4. The new ATI drivers don't work for "old" graphics cards such as the Radeon 4200.

The solution to this problem is described here: http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

The solution involves installation of unofficial packages. I tried it and it worked for me!

Cheers!

 
 
 
 
2
 
vote

Você pode abrir o arquivo:

    /etc/default/grub    

com o comando:

  gksu gedit /etc/default/grub    

e adicione esta linha a ele:

  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"    

(Certifique-se de substituir o ABCDEFGHIJKLMNABCDEFGHIJKLMN3 linha com isso, se houver um. Ou melhor, comentar a linha original, colocando um ABCDEFGHIJKLMNABCDEFGHIJKLMN4 Personagem no muito começo disso.)

Salve o arquivo, saia do editor de texto e execute este comando, que faz com que a nova configuração seja aplicada:

  sudo update-grub    

Se você fizer isso, então você não precisa instalar os drivers catalisadores da AMD, o que é ótimo!

 

You can open the file:

  /etc/default/grub 

With the command:

gksu gedit /etc/default/grub 

And add this line to it:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1" 

(Make sure to replace the existing GRUB_CMDLINE_LINUX_DEFAULT line with that if there is one. Or, even better, comment out the original line by putting a # character at the very beginning of it.)

Save the file, quit the text editor, and then run this command, which causes the new configuration to be applied:

sudo update-grub 

If you do that, then you don't have to install AMD's Catalyst drivers, which is great!

 
 
 
 

Perguntas relacionadas

15  Como faço para obter saída HDMI trabalhando em um Dell XPS 15 L502x?  ( How do i get hdmi output working on a dell xps 15 l502x ) 
Recentemente eu comprei o notebook do meu sonho, um Dell XPS 15, mas desde então este sonho se tornou uma espécie de pesadelo infinito. Estou quase ficando ...

2  Problemas Obtendo saída 4K (UHD) para Sony 65 "4K TV XBR-65X900A [FECHADO]  ( Problem getting 4k uhd output to sony 65 4k tv xbr 65x900a ) 
. FECHADO. Esta questão é off-tópico . Atualmente não está aceitando respostas. Quer melh...

2  Como faço para desabilitar a tela dupla depois de conectar cabo HDMI?  ( How do i disable dual screen after connect hdmi cable ) 
Eu conectei o conector HDMI e liguei o computador, mas quando a tela de login aparece, a tela do laptop aparece dividida em 2, uma parte superior e uma parte ...

0  PlayStation3 via entrada HDMI no problema de áudio do Ubuntu  ( Playstation3 via hdmi input on ubuntu audio issue ) 
Eu tenho um laptop Alienware M17XR3 com a entrada Radeon HD6990 e HDMI comutável. Quando eu conecto um PlayStation 3 tudo funciona bem, mas não há som. Al...

1  Dispositivos de áudio HDMI gráficos integrados estão faltando  ( Integrated graphics hdmi audio devices are missing ) 
Acabei de comprar um novo computador para usar como HTPC com o Ubuntu 12.04 64-bits, mas não consigo obter áudio HDMI para funcionar. Eu estou usando os gráfi...

1  As bordas do desktop Xubuntu são cortadas na minha TV Sony?  ( Edges of xubuntu desktop are cut off on my sony tv ) 
Eu instalei Xubuntu e parece funcionar bem, com uma exceção. Identificou minha 55 "Sony TV como 37" Sony. Normalmente eu não me importo, exceto que não poss...

5  Conectando duas telas externas ao laptop via VGA e HDMI  ( Plugging two external screens to laptop via vga and hdmi ) 
Eu tenho um laptop U30JC ASUS com uma porta VGA e HDMI. Eu posso conectar minha tela externa (1920x1200) para qualquer uma dessas portas, mas eu me pergunto s...

1  Nenhum sinal HDMI após a instalação e reinicialização  ( No hdmi signal after installing and rebooting ) 
até a reinicialização eu tenho um sinal via HDMI no meu monitor externo. depois não há nada - as configurações de exibição mostra apenas um monitor. Eu es...

2  Áudio intermitente do buzz / hdmi  ( Intermittent buzz hdmi audio ) 
Eu tenho um HTPC com uma placa-mãe ASUS P7H57D-V EVO e um processador / GPU I5. Eu estou usando o HDMI AUDIO para uma TV Panasonic. HTPC está executando o Ubu...

0  Eu tenho um problema com o som HDMI no Ubuntu 14 e no Windows 7, é esse hardware?  ( I have a problem with hdmi sound on both ubuntu 14 and windows 7 is this hardwa ) 
Eu tenho um problema com o som HDMI no Ubuntu 14 e no Windows 7, é esse hardware? O problema ocorre apenas ao executar jogos (algo intensivo de som) eu rece...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.