Nenhum "drivers adicionais" para Radeon 2100 sob Ubuntu 12.04 -- 12.04 campo com drivers campo com ati camp askubuntu Relacionado O problema

No “Additional Drivers” for Radeon 2100 under Ubuntu 12.04


0
vote

problema

português

Após a atualização para 12.04, ele não encontra drivers para o meu Radeon 2100 na janela "Drivers Adicionais". Não me lembro de ter problemas com isso antes. Mover janelas etc é muito lento, e eu suspeito que isso é por causa do driver que falta.

Existe uma maneira fácil de instalar o driver para Radeon 2100 no Ubuntu 12.04?

  $ lspci -nn | grep VGA 01:05.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Radeon 2100 [1002:796e]    

Digite a descrição da imagem aqui

english

After the upgrade to 12.04, it doesn't find drivers for my Radeon 2100 in the "Additional Drivers" window. I can't remember having problems with this before. Moving windows etc is very slow, and I suspect this is because of the missing driver.

Is there an easy way to install the driver for Radeon 2100 on Ubuntu 12.04?

$ lspci -nn | grep VGA 01:05.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Radeon 2100 [1002:796e] 

enter image description here

        

Lista de respostas

0
 
vote
vote
Melhor resposta
 
.

Suporte de catalisador ATI / AMD para esses cartões no Catalyst 9-4. Esses cartões são suportados com a liberação do catalisador Legacy ATI 9-3, mas você deve usar um kernel & lt; = 2.6.28 e xserver & lt; = 1,5. Por exemplo, você pode usar o Catalyst 9-3 se você estiver executando o Ubuntu 8.04 ou Debian Lenny / 5.0. O suporte de código aberto é bom e 3D ainda está melhorando.

( Fonte

Você não pode usar nenhum driver diferente do driver de código aberto em 12.04 desde que você não pode usar uma versão inferior do kernel apenas para fins de motoristas. Os drivers legados fornecidos pela AMD também não funcionarão com este cartão.

 

ATI/AMD dropped Catalyst support for these cards in Catalyst 9-4. These cards are supported with the legacy ATI 9-3 Catalyst release, but you MUST use a kernel <= 2.6.28 and Xserver <= 1.5. For example, you can use Catalyst 9-3 if you're running Ubuntu 8.04 or Debian Lenny/5.0. Open source support is good and 3D is still improving.

(source)

You cannot use any driver other than the open source driver in 12.04 since you cannot use a lower version of the kernel just for drivers purpose. The legacy drivers supplied by AMD will also no work with this card.

 
 
       
       
0
 
vote

znarkus,

A série X2100 de cartões Radeon é suportada sob os impulsionadores legados dos motoristas proprietários do catalisador e que podem ou não estar atualmente em desenvolvimento para precisão (não certo). Suspeito que as versões anteriores dos drivers poderiam funcionar, no entanto, não certas certas de que as versões atuais dos drivers catalisadores funcionarão para a série X2100, que pode ser por que eles não estão sendo mostrados como encontrado. As versões legadas podem não estar em desenvolvimento de precisão como uma alternativa e não podem ser dadas como uma opção. Um desenvolvedor pode saber de maneira diferente.

Sua melhor aposta pode ser tentar determinar qual versão dos drivers Catalyst foi a última versão para fornecer suporte para o seu cartão e tentar instalar esse driver manualmente a partir da fonte fornecida pela AMD. É provável que não seja tão limpo quanto um pacote debian das fontes, porém e exigiria reinstalar toda vez que o kernel for atualizado.

Outra escolha pode ser comprar uma placa de vídeo, elas são relativamente baratas nos dias de hoje e você pode obter um cartão ligeiramente mais recente que teria um driver disponível. Apenas outra opção embora.

Boa sorte, espero que isso ajude.

 

Znarkus,

The X2100 Series of Radeon cards are supported under the Legacy drivers of the Catalyst proprietary drivers and that may or may not be currently under development for Precise (not certain). Would suspect that the previous versions of the drivers might work, however not certain that the current versions of the Catalyst drivers will work for the X2100 series which may be why they are not being shown as found. The Legacy versions may not be under development for Precise as an alternative either and may not be given as an option. A developer may know differently though.

Your best bet may be to try to determine which version of the Catalyst Drivers was the last version to supply support for your card and try to install that driver manually from the source supplied by AMD. It is likely not to be as clean as a debian package from the sources though and would require reinstall every time the kernel is updated.

Another choice might be to buy a Video card, they are relatively inexpensive these days and you could get a slightly newer card that would have a driver available. Just another option though.

Good luck, hope this does help.

 
 
 
 
0
 
vote

Eu tenho o Radeon 2100 embutido na minha placa-mãe Acer Aspire. Eu estive executando o Debian e, como o Ubuntu é baseado no Debian, você provavelmente deve instalar o pacote Firmware-Linux-Nonfree. Ele tem o firmware necessário pelo driver Radeon 2100 e do Free X.org. O comando dmesg mostra que está procurando firmware rs690_cp.bin, que faz parte do pacote. Você deve ter o firmware para a aceleração da GPU. Eu tentei os drivers catalisadores e eles não funcionarão. Quando corri a instalação do Debian Wheezy Net, ele baixou e instalou os drivers gratuitos, mas não o firmware. Eu recebi a mensagem de que nenhum efeito 3D estava disponível até que eu tenha o firmware.

 

I have the Radeon 2100 built into my Acer Aspire motherboard. I've been running Debian and since Ubuntu is based on Debian, you probably should install the firmware-linux-nonfree package. It has the firmware needed by both the Radeon 2100 and the free x.org driver. The dmesg command shows that its looking for firmware RS690_cp.bin which is part of the package. You must have the firmware for GPU acceleration. I've tried the Catalyst drivers and they will not work. When I ran the Debian Wheezy net install, it downloaded and installed the free drivers but not the firmware. I got the message that no 3D effects were available until I got the firmware.

 
 

Perguntas relacionadas

3  Precisa de uma placa gráfica PCie Desktop para monitor duplo  ( Need a pcie desktop graphics card for dual monitor ) 
Eu tenho uma estação de trabalho de meados de 2008 com dois monitores HD que suportam entradas HDMI e DVI. Desde o Ubuntu 11.10, tenho experimentado nenhum f...

2  Não é possível obter gráficos para trabalhar no HP Pavilion G6  ( Cant get graphics to work on hp pavilion g6 ) 
Eu tenho este laptop HP Pavilion G6 de Crappy (nenhuma outra escolha, fornecida pelo Office), que está tendo problemas para lidar com gráficos (Ubuntu 12.04 L...

2  Como obter placa gráfica AMD funcionando bem 12.04?  ( How to get amd graphics card working well 12 04 ) 
Instalação fresca de 12,04 01: 05.0 VGA Controlador compatível: Micro dispositivos avançados [AMD] Nee ATI RS880 [Radeon HD 4200] 'Drivers adicionais' mos...

8  Laptop superaquece o Ubuntu 14.04  ( Laptop overheats running ubuntu 14 04 ) 
Eu instalei recentemente 14.04 no meu Toshiba Satellite 305D. Tem um AMD Athlon X2 Duel-Core e 2GB de Ram com Radeon 3100. Eu sei que ela não é muito, mas eu ...

7  GeForce e Radeon: O que é condição presente de openSource e motoristas proprietários?  ( Geforce and radeon what is present condition of opensource and proprietary driv ) 
Então, está prestes a comprar um videocard fresco. Desde que eu faço a maioria das minhas coisas no Linux, eu me pergunto o quão bem o videocard realizar. Rec...

1  AMD A8-4500 APU com Radeon HD 7640G  ( Amd a8 4500 apu with radeon hd 7640g ) 
Eu instalei muitas versões do Linux ultimamente, tentando me libertar do Windows, eu tocei com o Linux durante os últimos anos, mas eu estava em jogo, e até r...

1  Problema de gráficos comutáveis ​​AMD / Intel no Ubuntu 14.04  ( Amd intel switchable graphics problem in ubuntu 14 04 ) 
Eu estou tentando instalar o Ubuntu em um Lenovo G500, CPU é Intel Core i3-3110m, 4GB de RAM, e como você pode adivinhar, gráficos duplos: Intel HD 4000 para ...

3  Como escolher em que exibir a caixa de login aparecerá?  ( How to choose in which display the login box will appear ) 
Eu tenho dois monitores onde a área de trabalho é estendida. Eles estão conectados a uma placa de vídeo AMD / ATI através de cabos DVI. Quando eu inicializo o...

0  Monitor externo multi tela não reconhecido  ( Multi screen external monitor unrecognized ) 
Eu tenho o gerenciador de gráficos ATI (Catalyst Control Center) configurado para o meu monitor externo, conectado ao meu laptop Toshiba, e o monitor externo ...

3  Ícones de desktop fora de tela combinada exibição Ubuntu 14.10 Gnome 13.14  ( Desktop icons off screen combined display ubuntu 14 10 gnome 13 14 ) 
Eu tenho dois monitores lado a lado, ambos com a mesma resolução de 1680x1050, mas um é menor que o outro. Mas se eu organizá-los como tal, nas configurações ...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.