Atheros ar9485 cartão sem fio não funciona em um asus k53e -- wireless camp askubuntu Relacionado O problema

Atheros AR9485 wireless card doesn't work in an ASUS K53E


3
vote

problema

português

Acabei de instalar a versão Ubuntu 11.10 32 bits no modo de inicialização dupla em um Asus K53. Tudo parece funcionar bem, exceto pelo wireless. O wireless funciona no Windows 7. O Ubuntu encontra a placa sem fio, mas não parece ser ativada. O único meio físico de ligar o cartão é o combo de chave FN-F2. Que funciona no Windows, mas não no Ubuntu. Eu olhei nos fóruns para uma solução e não tenho certeza do que fazer. Eu colei as seguintes informações:

  jdwbmc@Spatha:~$ cat /etc/lsb-release; uname -a DISTRIB_ID=Ubuntu DISTRIB_RELEASE=11.10 DISTRIB_CODENAME=oneiric DISTRIB_DESCRIPTION="Ubuntu 11.10" Linux Spatha 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux  jdwbmc@Spatha:~$ lspci -nnk | grep -iA2 net 02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01) Subsystem: AzureWave Device [1a3b:1186] Kernel driver in use: ath9k -- 04:00.0 Ethernet controller [0200]: Atheros Communications AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0) Subsystem: ASUSTeK Computer Inc. Device [1043:1851] Kernel driver in use: atl1c  jdwbmc@Spatha:~$ lsusb Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 003: ID 058f:a014 Alcor Micro Corp.   jdwbmc@Spatha:~$ iwconfig lo no wireless extensions.  eth0 no wireless extensions.  wlan0 IEEE 802.11bgn ESSID off/any  Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm  Retry long limit:7 RTS thrff Fragment thrff Power Managementff  jdwbmc@Spatha:~$ rfkill list all 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: asus-wlan: Wireless LAN Soft blocked: no Hard blocked: no  jdwbmc@Spatha:~$ lsmod Module Size Used by parport_pc 32114 0  ppdev 12849 0  snd_hda_codec_hdmi 31426 1  bnep 17923 2  rfcomm 38408 0  bluetooth 148839 10 bnep,rfcomm snd_hda_codec_realtek 254125 1  binfmt_misc 17292 1  joydev 17393 0  asus_nb_wmi 12469 0  asus_wmi 19333 1 asus_nb_wmi sparse_keymap 13658 1 asus_wmi uvcvideo 67271 0  videodev 85626 1 uvcvideo snd_hda_intel 24262 2  snd_hda_codec 91754 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel snd_hwdep 13276 1 snd_hda_codec snd_pcm 80468 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec snd_seq_midi 13132 0  wmi 18744 1 asus_wmi snd_rawmidi 25241 1 snd_seq_midi snd_seq_midi_event 14475 1 snd_seq_midi snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event arc4 12473 2  i915 505108 3  snd_timer 28932 2 snd_pcm,snd_seq snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq ath9k 112711 0  psmouse 73673 0  serio_raw 12990 0  mac80211 272785 1 ath9k drm_kms_helper 32889 1 i915 ath9k_common 13599 1 ath9k drm 192226 4 i915,drm_kms_helper ath9k_hw 293893 2 ath9k,ath9k_common ath 19387 2 ath9k,ath9k_hw cfg80211 172392 3 ath9k,mac80211,ath snd 55902 14 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,s nd_seq,snd_timer,snd_seq_device soundcore 12600 1 snd snd_page_alloc 14115 2 snd_hda_intel,snd_pcm mei 36466 0  i2c_algo_bit 13199 1 i915 video 18908 1 i915 lp 17455 0  parport 40930 3 parport_pc,ppdev,lp ahci 21634 3  libahci 25727 1 ahci atl1c 36638 0  xhci_hcd 72915 0   jdwbmc@Spatha:/var/lib/NetworkManager$ cat NetworkManager.state  [main] NetworkingEnabled=true WirelessEnabled=true WWANEnabled=true WimaxEnabled=true  jdwbmc@Spatha:~$ lspci -nn | grep 0280 02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)    

Qualquer ajuda seria apreciada. Obrigado.

english

I just installed Ubuntu 11.10 32-bit version in dual boot mode on an ASUS K53. Every thing seems to work fine except for the wireless. The wireless works on Windows 7. Ubuntu finds the wireless card, but it does not appear to be turned on. The only physical means of turning on the card is the FN-F2 key combo. That works on Windows, but not in Ubuntu. I've looked in the forums for a solution and I'm not quite sure what to do. I've gathered the following information:

jdwbmc@Spatha:~$ cat /etc/lsb-release; uname -a DISTRIB_ID=Ubuntu DISTRIB_RELEASE=11.10 DISTRIB_CODENAME=oneiric DISTRIB_DESCRIPTION="Ubuntu 11.10" Linux Spatha 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux  jdwbmc@Spatha:~$ lspci -nnk | grep -iA2 net 02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01) Subsystem: AzureWave Device [1a3b:1186] Kernel driver in use: ath9k -- 04:00.0 Ethernet controller [0200]: Atheros Communications AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0) Subsystem: ASUSTeK Computer Inc. Device [1043:1851] Kernel driver in use: atl1c  jdwbmc@Spatha:~$ lsusb Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 003: ID 058f:a014 Alcor Micro Corp.   jdwbmc@Spatha:~$ iwconfig lo no wireless extensions.  eth0 no wireless extensions.  wlan0 IEEE 802.11bgn ESSID off/any  Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm  Retry long limit:7 RTS thrff Fragment thrff Power Managementff  jdwbmc@Spatha:~$ rfkill list all 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: asus-wlan: Wireless LAN Soft blocked: no Hard blocked: no  jdwbmc@Spatha:~$ lsmod Module Size Used by parport_pc 32114 0  ppdev 12849 0  snd_hda_codec_hdmi 31426 1  bnep 17923 2  rfcomm 38408 0  bluetooth 148839 10 bnep,rfcomm snd_hda_codec_realtek 254125 1  binfmt_misc 17292 1  joydev 17393 0  asus_nb_wmi 12469 0  asus_wmi 19333 1 asus_nb_wmi sparse_keymap 13658 1 asus_wmi uvcvideo 67271 0  videodev 85626 1 uvcvideo snd_hda_intel 24262 2  snd_hda_codec 91754 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel snd_hwdep 13276 1 snd_hda_codec snd_pcm 80468 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec snd_seq_midi 13132 0  wmi 18744 1 asus_wmi snd_rawmidi 25241 1 snd_seq_midi snd_seq_midi_event 14475 1 snd_seq_midi snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event arc4 12473 2  i915 505108 3  snd_timer 28932 2 snd_pcm,snd_seq snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq ath9k 112711 0  psmouse 73673 0  serio_raw 12990 0  mac80211 272785 1 ath9k drm_kms_helper 32889 1 i915 ath9k_common 13599 1 ath9k drm 192226 4 i915,drm_kms_helper ath9k_hw 293893 2 ath9k,ath9k_common ath 19387 2 ath9k,ath9k_hw cfg80211 172392 3 ath9k,mac80211,ath snd 55902 14 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,s nd_seq,snd_timer,snd_seq_device soundcore 12600 1 snd snd_page_alloc 14115 2 snd_hda_intel,snd_pcm mei 36466 0  i2c_algo_bit 13199 1 i915 video 18908 1 i915 lp 17455 0  parport 40930 3 parport_pc,ppdev,lp ahci 21634 3  libahci 25727 1 ahci atl1c 36638 0  xhci_hcd 72915 0   jdwbmc@Spatha:/var/lib/NetworkManager$ cat NetworkManager.state  [main] NetworkingEnabled=true WirelessEnabled=true WWANEnabled=true WimaxEnabled=true  jdwbmc@Spatha:~$ lspci -nn | grep 0280 02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01) 

Any help would be appreciated. Thanks.

  

Lista de respostas

0
 
vote

resolvido! Instalado Linux-Backports-Modules-CW e Atualização do Gerenciador de Rede. Funciona bem. O Linux-Backports-Modules-CW pode ser encontrado no centro de software e atualização do gerenciador de rede pode ser obtido via método normal do uodatina. Para qualquer um que precise desta informação em tukish navegar para minha entrada de blog: http : //gkaya93.blogspot.com/2012/05/ubuntu-1204-wireless-cozumu.html . Vou escrever uma descrição em inglês aqui:

  • Verifique a tabela nesta página para ver se sua placa sem fio (ou sth similar *) está lá: http://wiki.ubuntuusers.de/wlan/linux-backports-modules#enthaltene-treiber
  • se houver, faça o seguinte:
  • Vá ao terminal e entre "UNAME -R" para retornar a versão do kernel.
  • Pesquisa de uma versão correspondente de "Linux-Backports-Modules-CW" no centro de software. Instale-o.
  • atualizar o gerenciador de rede.
  • Reinicie e veja se isso afeta. Isso mudou muito minha experiência. É realmente melhor agora.

* Meu cartão foi RTL8192SE. Não foi incluído na mesa, em vez disso, RTL8180 / RTL8187. Mas o software curou meu sistema. Então vá em frente e tente se o modelo do seu cartão estiver perto de modelos incluídos. Eu acho que isso é mais seguro do que manipular arquivos de configuração do sistema.

e sth para incluir, no site, diz que o Linux-Backports-Modules-CW está incluído na imagem ao vivo, para que você possa instalar se não houver conexão. Eu não tentei, como formatei meu meio vivo. Mas se você não o fizesse, adicione-o às suas fontes de software e tente usar. - Centro de software e GT; Editar & GT; Fontes de software e GT; Instalável a partir de CD-ROM / DVD ... Verifique a caixa de seleção abaixo dela.

Eu acho que essa coisa funcionaria bem em versões idosas do Ubuntu, mas não tenho certeza e encorajando ninguém a experimentar por causa da minha palavra. Obrigado por qualquer suporte feito.

 

Solved! Installed linux-backports-modules-cw and network-manager update. Works well. linux-backports-modules-cw can be found in software center and network-manager update can be get via normal uodatin method. For anybody who needs this info in Tukish navigate to my blog entry : http://gkaya93.blogspot.com/2012/05/ubuntu-1204-wireless-cozumu.html . I will write an English description here:

  • Check the table in this page to see if your wireless card (or sth similar*) is there : http://wiki.ubuntuusers.de/WLAN/Linux-backports-modules#Enthaltene-Treiber
  • If there, do the following:
  • Go to terminal and enter "uname -r" for returning kernel version.
  • Search for a matching version of "linux-backports-modules-cw" in software center. Install it.
  • Update network-manager.
  • Reboot and see if it affects. It changed my experience a lot. It's really better now.

*My card was rtl8192se. It wasn't included in the table, instead, rtl8180/rtl8187. but the software healed my system. So go ahead and try if your card's model is close to included models. I guess this is safer than manipulating system configuration files.

And sth to include, on the website, it says that linux-backports-modules-cw is included in the Live image, so you can install if have no connection. I didn't try it, as I have formatted my live medium. But if you didn't, add it to your Software sources and try to use. - Software Center > Edit > Software sources > Installable from CD-ROM/DVD... Check the checkbox below it.

I guess this thing would work well in elderly Ubuntu versions, but I'm not sure and encouraging anyone to try it because of my word. Thanks for any support made.

 
 
 
 

Perguntas relacionadas

1  Broadcom BCM4313 funciona mal em um pavilhão HP G4-1212TU  ( Broadcom bcm4313 works poorly on a hp pavilion g4 1212tu ) 
Acabei de comprar um laptop HP Pavilion G4-1212TU e coloquei Ubuntu 11.10 nele. WiFi funciona mal. Normalmente pode se conectar (embora mostrando um nível de ...

1  Auto reconectar ao Wi-Fi  ( Auto reconnect to wi fi ) 
Quando abro meu laptop, leva cerca de 5 segundos para se reconectar à rede Wi-Fi. Existe uma maneira de uma conexão mais rápida? Talvez configure-o para não d...

3  Instalando o driver para Netgear WNA1100 WiFi Adapter - Ubuntu Server 12.04  ( Installing driver for netgear wna1100 wifi adapter ubuntu server 12 04 ) 
Eu comprei recentemente o adaptador WIFI WIM1100 para a caixa do Ubuntu Server 12.04. Desde que sou novo no Ubuntu, não consigo instalar os drivers para o ada...

3  Não é possível instalar drivers para o meu cartão WiFi Realtek RTL8723BE no Ubuntu 16.10  ( Cannot install drivers for my realtek rtl8723be wifi card in ubuntu 16 10 ) 
tentou $ sudo add-apt-repository ppa:hanipouspilot/rtlwifi $ sudo apt-get update $ sudo apt-get install rtlwifi-new-dkms linux-firmware mas dar ...

0  Cartão sem fio faz com que o Ubuntu 12.04 congele na inicialização  ( Wireless card causes ubuntu 12 04 to freeze on startup ) 
Atualmente estou executando o Ubuntu 12.04 64-bit com uma placa sem fio TP-link TL-WN851ND. Toda vez que eu inicio, em qualquer lugar entre 0 e 60 segundos ap...

1  Não é possível conectar-se ao repetidor de Wi-Fi ASUS no Ubuntu  ( Cant connect to asus wi fi repeater in ubuntu ) 
Então, adquiri recentemente um repetidor sem fio (ASUS RP-AC55) porque meu roteador não chegou a todos os lugares que precisava, mas até agora ele introduziu ...

1  Wifi driver não encontrado!  ( Wifi driver not found ) 
Estou executando o Ubuntu 14.10 no HP Pavilion P045TX Dual Booting com o Windows 8.1. Drivers WiFi não são encontrados. Como faço para instalar os drivers par...

3  Instala nova de 14.04 - agora incapaz de se conectar ao ponto de acesso UNIFI (outros funcionam)  ( Fresh install of 14 04 now unable to connect to unifi access point others wor ) 
Depois de instalar 14.04, não pode mais se conectar ao meu ponto de acesso UNIFI (trabalhado em 13,10 e funciona a partir do Windows na máquina de inicializaç...

9  REALTEK RTL8188CE driver sem fio instável no ubuntu 14.04  ( Realtek rtl8188ce wireless driver unstable in ubuntu 14 04 ) 
Desde uma nova instalação do Ubuntu 14.04 eu estou perdendo a conexão com a Internet após alguns minutos. Eu volto depois de reiniciar ou despertar do modo de...

1  Não é possível conectar-se à rede sem fio com um cartão WLAN Broadcom BCM4311 802.11b / g  ( Cannot connect to wireless network with a broadcom bcm4311 802 11b g wlan card ) 
Eu instalei o Ubuntu no meu antigo HP. É a versão 11.10. Não consigo descobrir como conectá-lo à minha rede sem fio. Eu não consigo nem conseguir para digital...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.