Nenhuma Internet, sem GCC, sem build-essents, nada funciona -- wireless campo com package-management campo com dependencies campo com compiling campo com gcc camp askubuntu Relacionado O problema

No Internet, No GCC, No Build-Essentials, NOTHING WORKS


0
vote

problema

português

Eu só quero dizer em frente que eu não postei isso levemente e eu literalmente passei as últimas 48 horas tentando descobrir isso sozinho, incluindo tentar seguir uma infinidade de tutoriais aqui e na web.

.

Frente inicial: Eu tenho uma nova instalação do Ubuntu 18.04 em uma partição no meu iMac Eu não tenho acesso à Internet (este é o principal problema e motivação para este post)

fatos:

  • eu sou um novo usuário do Linux
  • Eu instalei o Ubuntu 18.04 em uma partição do meu iMac
  • Eu não tenho acesso à Internet no sistema Linux
  • ubuntu não consegue encontrar meu adaptador WiFi
  • I Identifique meu adaptador Wi-Fi como uma transmissão BCM4630 e segui todos os tutoriais neste site e outros, tanto quanto possível, sem sucesso.
  • Eu quebrei e comprei outro adaptador sem fio um tp-link archer t4u

    • Eu estava seguindo as instruções de instalação do driver para o TP-Link Archer T4u
    • O comando que disse usar foi "fazer limpo"
    • Recebi um erro que não tenho "fazer" instalado, então tentei instalá-lo, mas diz que preciso ter "GCC" instalado, então eu tentei instalá-lo
    • nada disso funcionou, então eu tentei instalar "Build-essential"
    • Quando tento instalar o Build-essential, o GCC ou faça com que receba a seguinte saída com pequenas variações

"" " Ler lista de pacotes ... Edifício da árvore de dependência Reading State Information ... Feito Você pode querer executar 'APT --Fix-Broken Install' para corrigir estes. Os seguintes pacotes têm dependências não atendidas: Construa - essencial: depende: libc6-dev, mas não será instalado ... Depende: GCC, mas não será instalado e assim por diante e assim por diante "" "

Quando eu verificar se a compilação-essencial, o GCC ou a marca é instalada, diz que não é, mas pode ser com o sudo apt install ...

Eu tentei e tentei e tentei em todos eles. NADA FUNCIONA. Eu realmente estou tentando abordar isso como uma experiência de aprendizado, mas isso parece absolutamente insano neste momento e eu não sei o que fazer.

Toda vez que tento instalar algo, diz que outra coisa precisa ser instalada ad infinitum !! Tanto, que nem me lembro o que eu estava originalmente tentando instalar.

  • aqui é a minha última tentativa de resolver isso
  • eu baixei build-essent_12.8ubuntu1_amd64.deb
  • Eu tentei clicar duas vezes em instalar, mas não fez nada. Apenas perguntou - por minha senha, depois sentou-se lá e não fez nada.
  • Eu tentei instalar a partir da linha de comando com esta: sudo dpkg -i build-essential_12.8ubuntu1_amd64.deb
  • Recebi este erro: Os probelms de dependência impedem a configuração do build-essenciais:
  • build-essential depende de ... libc-dev, gcc, g ++, dpkg-dev

não é essencial para estar instalando estes ????????????????? Como isso pode depender do que é suposto instalar ???????????????????????????

Por favor, qualquer pessoa ajuda. Eu sinto que devo estar fazendo algo muito básico errado e que isso não é tão difícil quanto parece ser.

O Ubunto 18.04 realmente não vem com um GCC ou algum tipo de complilador C instalado ou programas básicos de construção, como fazer?

Eu só quero obter meu linux online, para que eu possa continuar a aprender. Por favor, ajude e lembre-se ... Eu não sei absolutamente nada sobre o Linux, então eu realmente apreciaria respostas básicas e passo a passo, se possível. Obrigado!

english

I just want to say up front that I do not post this lightly and I have literally spent the last 48 hours trying to figure this out myself, including trying to follow a plethora of tutorials on here and on the web.

Bottom Line Up Front: I have a new install of Ubuntu 18.04 on a partition on my iMac I DO NOT HAVE INTERNET ACCESS (This is the primary problem and motivation for this post)

Facts:

  • I am a new Linux user
  • I installed Ubuntu 18.04 on a partition of my iMac
  • I DO NOT HAVE INTERNET ACCESS on the Linux system
  • Ubuntu cannot find my wifi adapter
  • I identify my wifi adapter as a Broadcast BCM4630 and followed all the tutorials on this site and others as much as possible to no avail.
  • I broke down and bought another wireless adapter a TP-Link Archer T4U

    • I was following the driver installation instructions for the TP-Link Archer T4U
    • The command it said to use was "make clean"
    • I received an error that I do not have "make" installed, so I tried to install it, but it said I need to have "gcc" installed, so I tried to install it
    • None of that worked, so I tried to install "build-essential"
    • When I try to install build-essential, gcc, or make I get the following output with slight variations

""" Reading package list... Done Building dependency tree Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: build-essential : Depends : libc6-dev, but it is not going to be installed... Depends: gcc, but it is not going to be installed and so on and so on """

When I check to see if build-essential, gcc or make is installed it says that it is not, but it can be with sudo apt install ...

I've tried and tried and tried on all of them. NOTHING WORKS. I really am trying to approach this as a learning experience, but this just seems absolutely insane at this point and I do not know what to do.

Every time I try to install something, it says something else needs to be installed ad infinitum!! So much, that I don't even remember what I was originally trying to install.

  • HERE IS MY LAST ATTEMPT TO RESOLVE THIS
  • I downloaded build-essential_12.8ubuntu1_amd64.deb
  • I tried to double-click install it, but it did not do anything. It just asked - for my password, then sat there and did nothing.
  • I tried to install from command line with this: sudo dpkg -i build-essential_12.8ubuntu1_amd64.deb
  • I received this error: dependecy probelms prevent configuration of build-essential:
  • build-essential depends on... libc-dev, gcc, g++, dpkg-dev

ISN'T BUILD-ESSENTIAL SUPPOSED TO BE INSTALLING THESE???????????????????????? HOW CAN IT DEPEND ON WHAT IT IS SUPPOSED TO INSTALL??????????????????????????

Please, anyone help. I feel like I must be doing something very basic wrong and that this is not as hard as it appears to be.

Does Ubunto 18.04 really not come with a gcc or some kind of C compliler installed or basic build programs like make?

I just want to get my Linux online, so I can continue to learn. Please assist and remember... I know absolutely nothing about Linux, so I would really appreciate basic and step-by-step responses if possible. Thank you!

              
         
         

Lista de respostas


Perguntas relacionadas

1  Como faço para instalar o GCC 4.7.1 em 12.04?  ( How do i install gcc 4 7 1 on 12 04 ) 
Então acontece que eu acertei um bug no GCC 4.7.0 do Ubuntu, que foi corrigido em versões posteriores do GCC; Eu acredito que já é corrigido em 4.7.1. . Eu ...

2  Problema ao compilar GCC no Ubuntu  ( Problem when compiling gcc in ubuntu ) 
Eu corri para o problema bem conhecido ao instalar o GCC: configure:3605: error: in /usr/local/gcc-4.8.1/i686-pc-linux-gnu/libgcc': configure:3608: error: ...

2  Collect2: Erro Fatal: Não é possível encontrar a compilação 'LD' terminada  ( Collect2 fatal error cannot find ld compilation terminated ) 
Quando tento executar o programa C e C ++, estou recebendo dmesg0 Eu já instalei a versão mais recente GCC e G ++. ...

1  Como construir o aplicativo GUI na linguagem C usando GTK +?  ( How to build gui application in c language using gtk ) 
Eu tenho código escrito na linguagem C usando gtk. Este código fornece uma janela com 2 botões, mas eu não sei como tornar o aplicativo GUI independente deste...

4  Eclipse não consegue encontrar bibliotecas de índice de GCC ou G ++  ( Eclipse cant find index libraries of gcc or g ) 
A instalação das ferramentas do CDT no Eclipse não é possível encontrar em bibliotecas de índice de GCC ou G ++, mas o arquivo está sendo executado. Ex: Inc...

2  não pode compilar gcc ou g ++ libc_nonshared.a não reconhecido  ( Cannot compile gcc or g libc nonshared a not recognized ) 
Não consigo mais compilar arquivos C / C ++ mais desde o uso de uma nova conta (acho que foi desde então de qualquer maneira) e estou recebendo um erro estran...

22  Como atualizar o GCC para a versão mais recente (neste caso 4.7) no Ubuntu 10.04?  ( How to update gcc to the latest versionin this case 4 7 in ubuntu 10 04 ) 
Eu tenho ubuntu 10.04 32 bits com gcc 4.4.3 atualmente instalado nele. Eu quero atualizá-lo para gcc/g++ 4.7 (eu estou procurando suporte de C ++ 0x) Co...

0  O GCC não consegue encontrar Ansinist.h Mesmo que esteja lá em / usr / incudir / ansinist  ( Gcc cannot find ansinist h even though it is there in usr incude ansinist ) 
Estou tentando fazer um programa fornecido pela NIST. Eu não tenho muita experiência em tais tarefas. Eu estou recebendo o seguinte erro. util.c:19:22: f...

1  Como faço para instalar o GCC-4.6 no Ubuntu 15.10 (32bit edition)  ( How do i install gcc 4 6 on ubuntu 15 10 32bit edition ) 
Quando tento instalar o GCC-4.6 no Ubuntu15.10 (32bit edition) usando apt-get, mas não posso. Eu tentei, mas o Ubuntu exibiu essas mensagens de erro: $ s...

0  Incapaz de executar o Cudaminer em Jetson  ( Unable to run cudaminer on jetson ) 
Após o download e execução ./autogen.sh e ./configure a execução do comando Fazer fornece o seguinte erro no meu jetson tk1 . gcc -std = gnu99 -dhave_config...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.