Erro ao construir phpsh do terminal -- acos campo com terminal campo com python camp apple Relacionado O problema

error building phpsh from terminal


0
vote

problema

português

Estou seguindo as instruções na página do github phpsh Eu navego para o diretório phpsh e executo

python setup.py build

e eu recebo este erro

  Traceback (most recent call last):   File "setup.py", line 13, in <module>     p = Popen(["make", "-C", make_dir])   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 679, in __init__   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1228, in _execute_child OSError: [Errno 2] No such file or directory    

Parece que os arquivos no meu diretório Python realmente terminar em Pyo ...

Não tenho certeza do que fazer sobre isso

english

I am following the instructions on the phpsh github page I navigate to the phpsh directory and run

python setup.py build

and I get this error

Traceback (most recent call last):   File "setup.py", line 13, in <module>     p = Popen(["make", "-C", make_dir])   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 679, in __init__   File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1228, in _execute_child OSError: [Errno 2] No such file or directory 

it seems the files in my python directory actually end in pyo...

not sure what to do about this

        
 
 

Lista de respostas

1
 
vote

terminal aberto e digite which make para ver que você tem ferramentas de compilador mínimas instaladas.

Se não, baixe o xcode da App Store e tenha instalado as ferramentas da linha de comando.

 

Open terminal and type which make to see that you have minimal compiler tools installed.

If not, download Xcode from the App store and have it install the command line tools.

 
 

Perguntas relacionadas

2  Appstore API para pesquisa e download?  ( Appstore api for search and download ) 
Eu estou procurando uma API de Appstore, Oficial ou 3ª Parte, que me permitiria procurar (usando palavras-chave) e baixar aplicativos. Eu gostaria de baixar a...

1  Instalação Python desarrumada  ( Python installation messed up ) 
De alguma forma, meu python no meu Mac OS X está confuso. Eu estou tentando instalar virtualenv $ pip install virtualenv e isso me dá: Traceback...

1  Por que eu só tenho pip3, mas sem pip?  ( Why do i only have pip3 but no pip ) 
Eu instalei o Python3 de www.python.org (não através da Bravura). Eu descobri que não tinha pip, só pip3. Como aqui disse https://pip.pypa.Io/en/stable/insta...

0  Erro ao construir phpsh do terminal  ( Error building phpsh from terminal ) 
Estou seguindo as instruções na página do github phpsh Eu navego para o diretório phpsh e executo python setup.py build e eu recebo este erro Traceback...

3  Nivelador trabalhando com Catalina?  ( Levelator working with catalina ) 
Um grande aplicativo que usamos constantemente e é indiscutivelmente a ferramenta melhor (Free & amp; simples) para ajustar automaticamente os níveis de áudio...

1  Não é possível criar virtualenv  ( Cant create virtualenv ) 
Eu quero criar um virtualenv, mas não encontra o comando. $ virtualenv venv -bash: virtualenv: command not found Está instalado: $ pip install virtu...

1  Erro "criticamente baixo espaço" ao executar o script Python desde a atualização para OSX Mojave  ( Critically low disk space error when running python script since upgrade to os ) 
Eu tenho um problema com um script python que está sendo morto devido a, o que eu acredito, baixa memória disponível, mas espero que seja um bug. Descrição ...

2  Pyautogui não inserindo todos os caracteres ao usar a função de máquina de escrever  ( Pyautogui not entering all characters when using typewrite function ) 
Estamos tentando automatizar a caixa de diálogo SecurityAgent em que estamos inserindo a senha usando o PyautoGui em 10.13 OSX Senha = "12345678" usando ...

5  O Homebrew Vim com o suporte Python depende do Python 3.7.0, e eu tenho que usar 3.6.5  ( Homebrew vim with python support depends on python 3 7 0 and i have to use 3 6 ) 
Eu tenho que usar python 3.6.5 por causa de uma biblioteca eu uso que mantém mostrando bugs no 3.7.0 (tensorflow). Eu instalei python 3.6.5 usando hom...

0  Problema do servidor Python Play-with-MPV  ( Play with mpv python server problem ) 
Estou acostumada a usar ABCDEFGHIJKLMNABCDEFGHIJKLMN0 Extensão Chrome no Arch Linux, que funciona também em MacOS. O problema é que não está funcionando com...




© 2022 pergunte.org All Rights Reserved. Casa de perguntas e respostas todos os direitos reservados


Licensed under cc by-sa 3.0 with attribution required.